uncaught exception: [Exception... "Unexpected error" nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)" generated almost everywhere

RESOLVED FIXED

Status

SeaMonkey
General
RESOLVED FIXED
12 years ago
12 years ago

People

(Reporter: Gérard Talbot, Unassigned)

Tracking

({regression})

Trunk
x86
Windows XP
regression

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
Error: uncaught exception: [Exception... "Unexpected error"  nsresult:
"0x8000ffff (NS_ERROR_UNEXPECTED)"  location: "JS frame :: ...]
is being generated almost everywhere with today's build and breaking DHTML
functions.

Steps to reproduce:
1- Load provided URL
2- Open Javascript console and clear messages
3- Play around with the form: try setting column alignment, row alignment, table
border, cell border, caption side, collapse a row, etc.. 

Actual results: the functions fail to accomplish their expected tasks and
typical/constant error message (uncaught exception, "Unexpected error" 
nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)" fill the js console

Expected results: function succeeds without js error message

Reproducible: Always 
Seamonkey 1.1a rv: 1.9a1 build 2005100405 under XP Pro SP2 here

Note:
- Even when filing this very bug, the js console reported:
Error: uncaught exception: [Exception... "Unexpected error"  nsresult:
"0x8000ffff (NS_ERROR_UNEXPECTED)"  location: "JS frame ::
https://bugzilla.mozilla.org/js/productform.js :: get_selection :: line 363" 
data: no]
- Other files where I notice this happening: 
http://www.gtalbot.org/DHTMLSection/TableRowColumnCollapse.html
http://www.gtalbot.org/DHTMLSection/AdvancedCSSButtons.html
and possibly other webpages
- The bug is not happening is Firefox 1.4.1 rv: 1.8b5 build 20051003
- This must be a recent regression
- I can attach a reduced testcase if needed.

I could not find a duplicate for this.

Comment 1

12 years ago
Looks like bug 311090, too. The problem with https://bugzilla.mozilla.org/js/
productform.js is reported in bug 311104.
(Reporter)

Comment 2

12 years ago
Thanks for reporting that info, Erik. Since both bug 311104 and bug 311090 have
been fixed with checked in patches, I'll check again the webpages with
tomorrow's build.
(Reporter)

Comment 3

12 years ago
Everything works as expected with Seamonkey 1.1a rv:1.9a1 build 2005100505

Resolving as FIXED
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.