Music links open empty page in current window

RESOLVED DUPLICATE of bug 285319

Status

()

Firefox
File Handling
RESOLVED DUPLICATE of bug 285319
12 years ago
12 years ago

People

(Reporter: keith.freeman, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-GB; rv:1.7.12) Gecko/20050919 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-GB; rv:1.7.12) Gecko/20050919 Firefox/1.0.7

When you click on a "Listen Now" music link anywhere in www.allmusic.com,
Firefox opens a blank page in your current tab (headed "amg.dll (video/x-ms-asf
Object)") in order to launch the default mp3 player. So every time you listen to
a track you have to click Back in order to see where you were! IE doesn't do this.

Reproducible: Always

Steps to Reproduce:
1. Open www.allmusic.com
2. Click on any Listen Now link (loudspeaker icon).
3. 

Actual Results:  
Firefox exited the web page and replaced my current tab window with a blank one,
headed "amg.dll (video/x-ms-asf Object)" in order to launch the default mp3 player.

Expected Results:  
Launched the default mp3 player without exiting the web page.

Comment 1

12 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20051004
Firefox/1.6a1 ID:2005100413

This WFM. I the files are not mp3s, but rather asf music files. You need to set
some program (usually WMP) to handle these files. Possibly a dupe of bug 241972.

*** This bug has been marked as a duplicate of 285319 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.