CSS is not loaded because device's embedded server returns Content-Type application/octet-stream

RESOLVED DUPLICATE of bug 156145

Status

()

RESOLVED DUPLICATE of bug 156145
13 years ago
13 years ago

People

(Reporter: andrew.simmons, Assigned: mrbkap)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050512 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050920

The above URL is included only to provide the html code; I do not have any
problems viewing it.  The DGL-3420 (wireless bridge) that is attached to my
network card displays improperly formatted pages, and I also can not configure
the device from Linux.  This is because firefox and mozilla (latest build) do
not load the CSS, and I get the following error.

    Error: The stylesheet http://192.168.0.200/css_router_table.css was not 
    loaded because its MIME type, "application/octet-stream", is not "text/css".

I checked the HTTP header, and it is as expected:

    HTTP/1.1 200 OK
    Server: Embedded  HTTP Server 1.01
    Content-Type:  application/octet-stream Content-transfer-encoding: binary
    Content-Length: 18536
    Last-Modified : 4 Feb 2005 01: 49:58 GM
    Connection: close

The file really is a CSS.  Mozilla simply ignores the file because of it default
deny policy in this instance.  IE displays the pages correctly.  I also tried
contacting D-Link about the problem, but the tech rep I got told me that the
problem is with Mozilla.  I wasn't too impressed with D-Link's rep as he
apparently does not know Firefox is a brower and not a server.  If the issue is
with the webserver that my wireless bridge uses, could someone tell me what RFC,
section, page, and line backs up that claim?  That way I can write some harsh
letters to D-Link and know that I'm right.

Reproducible: Always

Steps to Reproduce:
1.Type in the IP address for the embedded web server for DGL-3420.  Out of the
box the address is "192.168.0.30".
2.
3.

Actual Results:  
Stylesheet was not loaded because the server returned content-type
application/octet-stream and Mozilla expected text/css.  So the web pages are
poorly formatted and the device's configuration can not be changed.

Expected Results:  
Loaded the stylesheet anyway.

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 156145 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.