M14 does not hyperlink if anchors are outside of paragraph tags

VERIFIED WORKSFORME

Status

()

P3
trivial
VERIFIED WORKSFORME
19 years ago
18 years ago

People

(Reporter: milhous, Assigned: rickg)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
When a page is poorly written with hyperlink anchors outside of a paragraph 
tag, M14 doesn't show the text within the paragraph as being hyperlinked.

Sample HTML:

<a href="http://www.mozilla.org/">
<p>This is the text left unlinked</p>
</a>

I noticed this on the Baseball Prospectus website at www.baseballprospectus.com 
(links on the upper right), but I think this particular HTML error is present 
in the way some WYSIWYG editors write.

Derek

Comment 1

19 years ago
Having to do with the parser. Reassigning.
Assignee: cbegle → rickg
Component: Browser-General → Parser
QA Contact: asadotzler → janc

Comment 2

19 years ago
this worksfrome on m16 nightlies.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME

Comment 3

19 years ago
*** Bug 48002 has been marked as a duplicate of this bug. ***

Comment 4

18 years ago
Verified
Platform: PC
OS: Windows 98
Mozilla Build: 2000101020 M18 Trunk Build
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.