crash while processing netcenter's activation pages...

VERIFIED INVALID

Status

P1
critical
VERIFIED INVALID
19 years ago
10 years ago

People

(Reporter: racham, Assigned: saari)

Tracking

({crash})

Trunk
x86
Windows NT
crash

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2+])

(Reporter)

Description

19 years ago
Assigning to saari. Got his name from cvs blame (stack trace at the bottom).

Steps to reproduce...

1. turn your pref warn me before setting cookie to on..
2. open the browser and type 
http://ins-group1.netscape.com:9999/activation/en/activation.cgi in the url bar. 
3. You will go to netcenter's activation page. Enter the data on the first page.
4. On the second page which says, your necenter screen name accpeted, click on 
OK....you will see an alert with the text under13****.
5. Click on the alert. CRASH....

Do we know why is this happening...? This didn't happen with M13 builds. 

Following the stack trace... 


nsGenericElement::HandleDOMEvent(nsIPresContext * 0x0331ba80, nsEvent * 
0x0012be2c, nsIDOMEvent * * 0x0012ba10, unsigned int 1, nsEventStatus * 
0x0012be50) line 996 + 33 bytes
nsGenericHTMLElement::HandleDOMEventForAnchors(nsIPresContext * 0x0331ba80, 
nsEvent * 0x0012be2c, nsIDOMEvent * * 0x00000000, unsigned int 1, nsEventStatus 
* 0x0012be50) line 804 + 31 bytes
nsHTMLAnchorElement::HandleDOMEvent(nsHTMLAnchorElement * const 0x0411856c, 
nsIPresContext * 0x0331ba80, nsEvent * 0x0012be2c, nsIDOMEvent * * 0x00000000, 
unsigned int 1, nsEventStatus * 0x0012be50) line 342
nsEventStateManager::SendFocusBlur(nsEventStateManager * const 0x03f73e10, 
nsIPresContext * 0x0331ba80, nsIContent * 0x0411856c) line 2380
nsEventStateManager::SetContentState(nsEventStateManager * const 0x03f73e10, 
nsIContent * 0x0411856c, int 2) line 2164
nsHTMLAnchorElement::SetFocus(nsHTMLAnchorElement * const 0x04118570, 
nsIPresContext * 0x0331ba80) line 244
nsEventStateManager::PreHandleEvent(nsEventStateManager * const 0x032c21b0, 
nsIPresContext * 0x0105e7c0, nsGUIEvent * 0x0012c3b0, nsIFrame * 0x00f2c9b8, 
nsEventStatus * 0x0012c318, nsIView * 0x0105f850) line 563
PresShell::HandleEvent(PresShell * const 0x0105cd94, nsIView * 0x0105f850, 
nsGUIEvent * 0x0012c3b0, nsEventStatus * 0x0012c318) line 3005 + 43 bytes
nsView::HandleEvent(nsView * const 0x0105f850, nsGUIEvent * 0x0012c3b0, unsigned 
int 28, nsEventStatus * 0x0012c318, int & 0) line 799
nsViewManager2::DispatchEvent(nsViewManager2 * const 0x0105fb10, nsGUIEvent * 
0x0012c3b0, nsEventStatus * 0x0012c318) line 1216
HandleEvent(nsGUIEvent * 0x0012c3b0) line 69
nsWindow::DispatchEvent(nsWindow * const 0x0105f724, nsGUIEvent * 0x0012c3b0, 
nsEventStatus & nsEventStatus_eIgnore) line 493 + 10 bytes
nsWindow::DispatchWindowEvent(nsGUIEvent * 0x0012c3b0) line 514
nsWindow::DispatchFocus(unsigned int 106) line 3120 + 15 bytes
nsWindow::ProcessMessage(unsigned int 7, unsigned int 103023782, long 0, long * 
0x0012c614) line 2352 + 19 bytes
nsWindow::WindowProc(HWND__ * 0x000d09ae, unsigned int 7, unsigned int 
103023782, long 0) line 671 + 27 bytes
USER32! 77e719d0()
USER32! 77e71982()
NTDLL! 77f763a3()
GlobalWindowImpl::Focus(GlobalWindowImpl * const 0x02d8a7f8) line 1222 + 23 
bytes
nsWebShellWindow::HandleEvent(nsGUIEvent * 0x0012c874) line 519
nsWindow::DispatchEvent(nsWindow * const 0x02d8ea14, nsGUIEvent * 0x0012c874, 
nsEventStatus & nsEventStatus_eIgnore) line 493 + 10 bytes
nsWindow::DispatchWindowEvent(nsGUIEvent * 0x0012c874) line 514
nsWindow::DispatchFocus(unsigned int 104) line 3120 + 15 bytes
nsWindow::ProcessMessage(unsigned int 7, unsigned int 5704148, long 0, long * 
0x0012cad8) line 2349 + 19 bytes
nsWindow::WindowProc(HWND__ * 0x062404a6, unsigned int 7, unsigned int 5704148, 
long 0) line 671 + 27 bytes
USER32! 77e719d0()
USER32! 77e71982()
NTDLL! 77f763a3()
USER32! 77e718d2()
nsWindow::DefaultWindowProc(HWND__ * 0x062404a6, unsigned int 6, unsigned int 1, 
long 788918) line 698
USER32! 77e727fe()
USER32! 77e72889()
nsWindow::WindowProc(HWND__ * 0x062404a6, unsigned int 6, unsigned int 1, long 
788918) line 678 + 31 bytes
USER32! 77e719d0()
USER32! 77e71982()
NTDLL! 77f763a3()
nsXULWindow::Destroy(nsXULWindow * const 0x0394a254) line 381
nsChromeTreeOwner::Destroy(nsChromeTreeOwner * const 0x0394edf4) line 211
GlobalWindowImpl::Close(GlobalWindowImpl * const 0x0394e2c8) line 1549
GlobalWindowImpl::CloseWindow(nsISupports * 0x0394e2c4) line 2801
nsJSContext::ScriptEvaluated(nsJSContext * const 0x0394eb30) line 753 + 18 bytes
nsJSContext::CallEventHandler(nsJSContext * const 0x0394eb30, void * 0x02f8cf80, 
void * 0x02f8cf88, unsigned int 1, void * 0x0012ce44, int * 0x0012ce40) line 570
nsJSEventListener::HandleEvent(nsIDOMEvent * 0x03f6eef4) line 128 + 57 bytes
nsEventListenerManager::HandleEventSubType(nsListenerStruct * 0x039a7cd0, 
nsIDOMEvent * 0x03f6eef4, unsigned int 4, unsigned int 7) line 697 + 19 bytes
nsEventListenerManager::HandleEvent(nsIPresContext * 0x0399d860, nsEvent * 
0x0012d378, nsIDOMEvent * * 0x0012d340, unsigned int 7, nsEventStatus * 
0x0012d63c) line 837 + 29 bytes
nsXULElement::HandleDOMEvent(nsXULElement * const 0x039a7e10, nsIPresContext * 
0x0399d860, nsEvent * 0x0012d378, nsIDOMEvent * * 0x0012d340, unsigned int 1, 
nsEventStatus * 0x0012d63c) line 3107
nsEventStateManager::CheckForAndDispatchClick(nsEventStateManager * const 
0x039ee3d0, nsIPresContext * 0x0399d860, nsMouseEvent * 0x0012d730, 
nsEventStatus * 0x0012d63c) line 1708 + 42 bytes
nsEventStateManager::PostHandleEvent(nsEventStateManager * const 0x039ee3d0, 
nsIPresContext * 0x0399d860, nsGUIEvent * 0x0012d730, nsIFrame * 0x02fbf038, 
nsEventStatus * 0x0012d63c, nsIView * 0x0399e970) line 891 + 24 bytes
PresShell::HandleEvent(PresShell * const 0x0399e404, nsIView * 0x0399e970, 
nsGUIEvent * 0x0012d730, nsEventStatus * 0x0012d63c) line 3031 + 43 bytes
nsView::HandleEvent(nsView * const 0x0399e970, nsGUIEvent * 0x0012d730, unsigned 
int 28, nsEventStatus * 0x0012d63c, int & 0) line 799
nsViewManager2::DispatchEvent(nsViewManager2 * const 0x0399ec30, nsGUIEvent * 
0x0012d730, nsEventStatus * 0x0012d63c) line 1216
HandleEvent(nsGUIEvent * 0x0012d730) line 69
nsWindow::DispatchEvent(nsWindow * const 0x0399e844, nsGUIEvent * 0x0012d730, 
nsEventStatus & nsEventStatus_eIgnore) line 493 + 10 bytes
nsWindow::DispatchWindowEvent(nsGUIEvent * 0x0012d730) line 514
nsWindow::DispatchMouseEvent(unsigned int 301, nsPoint * 0x00000000) line 2974 + 
21 bytes
ChildWindow::DispatchMouseEvent(unsigned int 301, nsPoint * 0x00000000) line 
3192
nsWindow::ProcessMessage(unsigned int 514, unsigned int 0, long 3342613, long * 
0x0012d9cc) line 2260 + 24 bytes
nsWindow::WindowProc(HWND__ * 0x005709d4, unsigned int 514, unsigned int 0, long 
3342613) line 671 + 27 bytes
USER32! 77e71820()
JS3250! js_ErrorFormatString + 2541 bytes

Updated

19 years ago
Severity: normal → critical
Keywords: crash
(Reporter)

Comment 1

19 years ago
*** Bug 31342 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M16

Comment 2

19 years ago
Mass-moving all M16 non-feature bugs to M17, which we still consider to be 
part of beta2
Target Milestone: M16 → M17

Comment 3

19 years ago
nominating for nsbeta2
Keywords: nsbeta2
Priority: P3 → P1

Comment 4

19 years ago
[nsbeta2+], fixing content on server-side would be okay too.
Whiteboard: [nsbeta2+]

Updated

19 years ago
Blocks: 40158

Comment 5

19 years ago
Adding netcenter keyword.
Keywords: netcenter
QA Contact: asadotzler → gbush
(Assignee)

Comment 6

19 years ago
I get a server error when trying to get to the URL. Please update the example
Component: Browser-General → Compositor
(Reporter)

Comment 7

19 years ago
ins-group1.netscape.com is a test server. Right now, no one on netcenter team 
seems to be looking after this server. The actual URL 
http://activation.netcsape.com/activation/en/activation.cgi has no such alerts. 
Alerts reported in this bug were more for debug puposes on test server. 

One dialog (Similar to alerts thrown on test servers) I found on new URL is 
the confirmation dialog that comes up, when you click on Cancel button on the 
first screen. Choosing one of those buttons (on this dialog) decides the right 
action. This works fine. Activation pages are now processed without any 
problems.

So, in the current context, this bug is not valid anymore. 
Saari...taking the liberty to mark this invalid.
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → INVALID

Comment 8

19 years ago
ok
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.