Permissions not inherited from parent dir, for newly downloaded file

RESOLVED DUPLICATE of bug 224692

Status

()

RESOLVED DUPLICATE of bug 224692
13 years ago
10 years ago

People

(Reporter: chichisan, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

On a multiuser permissions (group permissions) set to a directory, the download
manager fails to inherit those permissions on a newly downloaded file into this
directory. It only set permissions for the user which has downloaded the file.
I use a NTFS partision so any new file must inherit its parent directory
permissions.

Reproducible: Always

Steps to Reproduce:
1. Set permissions for a dir to a two or more users.
2. Download a file in that directory.
3. Check file permissions.

Actual Results:  
The newly downloaded file doesn't inherit its parent permissions.

Expected Results:  
On a NTFS partision any new file must inherit its parent directory permissions.

Comment 1

13 years ago
Isn't this an OS issue?

Comment 2

13 years ago
Duplicate of Core bug 224692?
(Reporter)

Comment 3

13 years ago
No, it's not an OS issue, because other browsers handle this well.

And, no, is not a duplication of Core bug 224692, 'cause the drive is not
compressed, either the directory where the data is downloaded.

Comment 4

13 years ago
This is a dupe. You misread the summary of bug 224692. It says that /properties/
like permission, compression, encryption are not inherited. Your bug falls under
the first mentioned property.

*** This bug has been marked as a duplicate of 224692 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.