If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Enable SVG by default in configure

RESOLVED FIXED in Firefox1.5

Status

()

Firefox
Build Config
P2
normal
RESOLVED FIXED
12 years ago
11 years ago

People

(Reporter: Benjamin Smedberg, Assigned: Benjamin Smedberg)

Tracking

1.5.0.x Branch
Firefox1.5
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Assignee)

Description

12 years ago
Now that everyone is using cairo, we can and should enable SVG/canvas by default
for Firefox on the 1.8 branch. (We should do this on the trunk too, but that
depends on the cairo upgrade on trunk which hasn't happened yet). This may
require adding --disable-svg --disable-canvas to a couple of the older branch
tinderboxen which can't build cairo (balsa and maybe crazyhorse).
(Assignee)

Comment 1

12 years ago
Created attachment 198574 [details] [diff] [review]
Enable SVG/Canvas by default for Firefox (branch)
Attachment #198574 - Flags: superreview?(chase)
Attachment #198574 - Flags: review?(tor)
(Assignee)

Updated

12 years ago
Priority: -- → P2
Target Milestone: --- → Firefox1.5

Comment 2

12 years ago
Don't you want to flip the language/logic of the tests for those options to
reflect the new defaults?
(Assignee)

Comment 3

12 years ago
not really: shifting internal varnames isn't generally worth it.

Updated

12 years ago
Attachment #198574 - Flags: review?(tor) → review+
Version: unspecified → 1.5 Branch

Updated

12 years ago
Hardware: PC → All
Attachment #198574 - Flags: superreview?(chase) → superreview+
(Assignee)

Comment 4

12 years ago
Created attachment 212899 [details] [diff] [review]
Fixed up

This has the same affect for browser but is slightly more elegant (and defaults on for xulrunner and seamonkey).
Attachment #198574 - Attachment is obsolete: true

Comment 5

12 years ago
My nightly Thunderbird trunk clobber build seems to be having trouble with this change. It's still ending up with MOZ_SVG_FOREIGNOBJECT getting defined. Do we need to explicitly set this to an empty value as well?

Building deps for nsLayoutUtils.cpp
-DWINVER=0x500 -D_WIN32_WINNT=0x500 -DSTDC_HEADERS=1 -DWIN32_LEAN_AND_MEAN=1 -DNO_X11=1 -D_X86_=1 -DD_INO=d_ino -DMOZ_DEFAULT_TOOLKIT=\"cairo-windows\" -DMOZ_THEBES=1 -DMOZ_CAIRO_GFX=1 -DMOZ_THUNDERBIRD=1 -DMOZ_BUILD_APP=mail -DNS_PRINTING=1 -DNS_PRINT_PREVIEW=1 -DMOZ_XTF=1 -DMOZ_SVG_FOREIGNOBJECT=1 /cygdrive/c/build/trees/tbirddbg/mozilla/layout/base/nsLayoutUtils.cpp
nsLayoutUtils.cpp
c:/build/trees/tbirddbg/mozilla/layout/base/nsLayoutUtils.cpp(59) : fatal error C1083: Cannot open include file: 'nsSVGForeignObjectFrame.h': No such file or directory
make[5]: Leaving directory `/cygdrive/c/build/trees/tbirddbg/mozilla/layout/base'

Comment 6

12 years ago
I suspect the Patrocles Tinderbox machine will show the same error once Stuart and I figure out why it's unhappy in nsWindow.cpp
(Assignee)

Comment 7

12 years ago
That's a different (but real) bug: roc's svg-foreignobject patch sets
MOZ_SVG_FOREIGNOBJECT=$MOZ_ENABLE_CAIRO_GFX without any MOZ_SVG check.

This is fixed on trunk.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Created attachment 212950 [details] [diff] [review]
fix foreignobject when SVG is disabled
Attachment #212950 - Flags: review?
Attachment #212950 - Flags: review? → review?(benjamin)
(Assignee)

Updated

12 years ago
Attachment #212950 - Flags: review?(benjamin) → review+
I checked that in.

Comment 10

12 years ago
BeOS Firefox builds may have been broken by this build - fails during initial tests - configure: error: Library requirements (fontconfig freetype2) not met; missing pkg-config.  Thunderbird still builds OK.  will investigate and open new bug if it's a regression.

Comment 11

12 years ago
This checkin broke the AIX Tinderbox - the fix is simple enough. The following C++ style comments need to be changed to C style comments:

/home/tbox/sb/tinderbox/AIX_5.1_Clobber/mozilla/gfx/cairo/libpixman/src/fbcompose.c
"/home/tbox/sb/tinderbox/AIX_5.1_Clobber/mozilla/gfx/cairo/libpixman/src/fbcompose.c", line 47.4: 1506-191 (E) The character # is not a valid C source character.
"/home/tbox/sb/tinderbox/AIX_5.1_Clobber/mozilla/gfx/cairo/libpixman/src/fbcompose.c", line 48.4: 1506-191 (E) The character # is not a valid C source character.
"/home/tbox/sb/tinderbox/AIX_5.1_Clobber/mozilla/gfx/cairo/libpixman/src/fbcompose.c", line 47.1: 1506-046 (S) Syntax error.
(In reply to comment #10)
> BeOS Firefox builds may have been broken by this build - fails during initial
> tests - configure: error: Library requirements (fontconfig freetype2) not met;
> missing pkg-config. 

You need to install those or use --disable-svg --disable-canvas.
Blocks: 339722

Updated

11 years ago
Blocks: 122092
You need to log in before you can comment on or make changes to this bug.