Start page doesn't take RTL in RTL interface

RESOLVED FIXED in Thunderbird1.1

Status

RESOLVED FIXED
13 years ago
11 years ago

People

(Reporter: linxspider, Assigned: linxspider)

Tracking

(Blocks: 1 bug, {fixed1.8, rtl})

unspecified
Thunderbird1.1
x86
Windows XP
fixed1.8, rtl

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments, 2 obsolete attachments)

(Assignee)

Description

13 years ago
in RTL interface the start page doesn't take RTL direction.

steps to reproduce:

1. download RTL build from:
ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-mozilla1.8-l10n/thunderbird-1.4.1.he.win32.zip

2. open Thunderbird and look at the start page.
(Assignee)

Comment 1

13 years ago
Created attachment 198612 [details]
images compatible with rtl ui
Attachment #198612 - Flags: review?(bugs.mano)
(Assignee)

Comment 2

13 years ago
Created attachment 198614 [details] [diff] [review]
adding the files to jar.mn

adding the files to messenger.jar. the image files go in
mozilla/mail/base/content
(Assignee)

Updated

13 years ago
Attachment #198614 - Flags: review?(bugs.mano)
(Assignee)

Comment 3

13 years ago
Created attachment 198948 [details] [diff] [review]
adding RTL support to start.xhtml
Assignee: bugs.mano → linxspider
Status: NEW → ASSIGNED
(Assignee)

Updated

13 years ago
Attachment #198612 - Flags: review?(bugs.mano) → superreview?(mscott)
(Assignee)

Updated

13 years ago
Attachment #198948 - Flags: superreview?(mscott)
Attachment #198948 - Flags: review?(bugs.mano)
Comment on attachment 198948 [details] [diff] [review]
adding RTL support to start.xhtml


> ul {
>   margin-left: 30px;
>   padding-left: 0px;
>   line-height: 1.2em;
> }
> 
>+body[dir="rtl"] ul {
>+  margin-right: 30px;
>+  padding-right: 0px;
>+  line-height: 1.2em;
>+}
>+


Try the following style rule instead of the two:
 ul {
   -moz-margin-start: 30px;
   -moz-padding-start: 0px;
   line-height: 1.2em;
 }

r=mano with that fixed; needs moa from mscott.
Attachment #198948 - Flags: review?(bugs.mano) → review+
Comment on attachment 198614 [details] [diff] [review]
adding the files to jar.mn

r=mano
Attachment #198614 - Flags: superreview?(mscott)
Attachment #198614 - Flags: review?(bugs.mano)
Attachment #198614 - Flags: review+
(Assignee)

Comment 6

13 years ago
(In reply to comment #4)
 
> Try the following style rule instead of the two:
>  ul {
>    -moz-margin-start: 30px;
>    -moz-padding-start: 0px;
>    line-height: 1.2em;
>  }

doesn't seem to have any affect...

Updated

13 years ago
Attachment #198612 - Flags: superreview?(mscott) → superreview+

Updated

13 years ago
Attachment #198614 - Flags: superreview?(mscott) → superreview+

Comment 7

13 years ago
Comment on attachment 198948 [details] [diff] [review]
adding RTL support to start.xhtml

Mano's CSS suggestion should  work and is the right way to do this. I'm going
to check this in as is for now but if you could figure out why his suggestion
did not work for you, I would appreciate it. Thanks.
Attachment #198948 - Flags: superreview?(mscott) → superreview+

Comment 8

13 years ago
fixed on the trunk

Comment 10

13 years ago
(In reply to comment #9)
> Scott, can this go on the branch?

Once we get the RTL theme squared away on the branch, then yes :)
(Assignee)

Comment 11

13 years ago
(In reply to comment #7)
> (From update of attachment 198948 [details] [diff] [review] [edit])
> Mano's CSS suggestion should  work and is the right way to do this. I'm going
> to check this in as is for now but if you could figure out why his suggestion
> did not work for you, I would appreciate it. Thanks.
> 

moz-margin and moz-padding are styles unique to the xul language and are not
part of Html or Xhtml.
That's is a false assertion, see the way we use it in html.css for lists.

<snaky>CSS isn't a part (x)html.</snaky>
(Assignee)

Comment 13

13 years ago
(In reply to comment #12)
> That's is a false assertion, see the way we use it in html.css for lists.
> 
> <snaky>CSS isn't a part (x)html.</snaky>

still doesn't seem to have any effect... is it possible it's not applies in
xhtml (not html)?

Comment 14

13 years ago
Reuven, how is this looking on the trunk now that it's all checked in? We don't
have the ability to verify these changes ourselves, we need your help. 
(Assignee)

Comment 15

13 years ago
O.K forgive me, this looks like my own mess up. the moz-margin does work, but
for some reason i didn't add the '-' before the moz-margin-side  :-\

i will attach a fix for this soon.

mscott: the start page currently looks good in both directions.
(Assignee)

Comment 16

13 years ago
Created attachment 199690 [details] [diff] [review]
using -moz styles instead of margin(padding)-right(left)

this patch uses the -moz-margin-start(end) instead of margin-right(left) for
the margins and paddings.
(Assignee)

Updated

13 years ago
Attachment #199690 - Flags: review?(mscott)
(Assignee)

Comment 17

13 years ago
Created attachment 200192 [details] [diff] [review]
same as above, removing rtl branding styles

this patch uses the moz styles with the branding rtl image
(thunderbird-watermark-rtl) removed.
Attachment #199690 - Attachment is obsolete: true
(Assignee)

Comment 18

13 years ago
Created attachment 200193 [details] [diff] [review]
as above, fixing the watermark location

oops... we still need to align the watermark to the left in RTL interface.
Attachment #200192 - Attachment is obsolete: true
(Assignee)

Updated

13 years ago
Attachment #200193 - Flags: superreview?(mscott)
Attachment #200193 - Flags: review?(bugs.mano)
Comment on attachment 200193 [details] [diff] [review]
as above, fixing the watermark location

r=mano
Attachment #200193 - Flags: review?(bugs.mano) → review+

Updated

13 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Keywords: fixed1.8
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird1.1

Updated

13 years ago
Attachment #199690 - Flags: review?(mscott)

Updated

13 years ago
Attachment #200193 - Flags: superreview?(mscott) → superreview+

Comment 20

11 years ago
Mass-assigning the new rtl keyword to RTL-related (see bug 349193).
Keywords: rtl
You need to log in before you can comment on or make changes to this bug.