Caret shifts one paragraph while typing 3rd character in reply

RESOLVED FIXED in M15

Status

MailNews Core
Composition
P3
normal
RESOLVED FIXED
18 years ago
9 years ago

People

(Reporter: Jim Roskind, Assigned: Joe Francis)

Tracking

({regression})

Trunk
regression

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT-])

(Reporter)

Description

18 years ago
Set your pref to send email in rich text html.
Get a message that has a paragraph of html
Press reply
Note that message is quoted, with blue bar at left (HTML quoting)
Using mouse, place curson in the middle of a line of text, around the middle of
a paragraph
Press enter (new line)
Note that quoting splits the sentence in the middle, and places cursor at left
margin.
Type two key strokes, such as 12
Note that the characters appear where you typed them.
Press a third key, such as 3
Note that the 3 appears after the remainder of the quoted paragraph, several
lines later in the message

The expected result was of course that the 3 would appear just after the 1 and 2.

This regression just happened in yesterday's build.

It is present in the afternoon build for 3/8/2000


I don't know if it is too late to get a fix in for beta... but having a fix in
hand will certainly help to have a shot at making this change for beta1.
(Reporter)

Comment 1

18 years ago
Nominating for beta1... just in case it can make it :-/
Keywords: beta1

Comment 2

18 years ago
Tested on commercial Mac bits from yesterday afternoon (2pm).
I don't see this problem on Mac.

Can anyone else reproduce this problem?

Since it is not a crasher, I recommend that it be PDT-.
Keywords: regression
Target Milestone: M15
I'm able to reproduce this on a release build from today on linux.

For what it's worth, after this triggers I get it to happend again if I click on
a line *above* the one I clicked on (and press return and start typing), but not
if I click on a line below the one I clicked on the first time.
(Assignee)

Comment 4

18 years ago
strange: to my knowledge no related editor code has changed across the last few 
days.  I wonder if this can happen with earlier builds?

Comment 5

18 years ago
I don't see this, on the commercial 3/9 linux build.

I wonder if this could be some sort of timing related problem?  Not that I can
think of anything that *should* be timing related here ...

Comment 6

18 years ago
Oh, cool.  A few minutes after I added that comment, replying to chofmann's
"things that block branching" text/plain message with a multipart/alternative
attachment, hitting return at the end of one of the plaintext lines, I saw the
behavior: on the third character, just as described, the caret jumped to the end
of the message (but before the attachment) and split the blockquote there.

I can reproduce this every time on this particular message.  No immediate clue
why it's happening.  Joe, any suggestions on where I should set breakpoints or
put printfs?
(Assignee)

Comment 7

18 years ago
i've been able to reproduce this on akkana's mac, and get some initial insight 
there.  I'm going to try to debug it further on my machine.  stay tuned...
Status: NEW → ASSIGNED

Comment 8

18 years ago
Putting on PDT- radar for beta1.

Whiteboard: [PDT-]

Comment 9

18 years ago
I was able to reproduce this on a Win32 build yesterday as per jar's 
instructions.
OS: Windows NT → All
Hardware: PC → All

Comment 10

18 years ago
This is actually a "caret" issue (not a cursor bug).
Summary: Cursor shifts one paragraph while typing 3rd character in reply → Caret shifts one paragraph while typing 3rd character in reply
(Assignee)

Comment 11

18 years ago
fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.