Regressions: searching/filtering works worse in 20051005 than it did in 2005011112

RESOLVED INVALID

Status

Calendar
Sunbird Only
--
major
RESOLVED INVALID
12 years ago
12 years ago

People

(Reporter: Fred, Assigned: Mostafa Hosseini)

Tracking

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20051005 Mozilla Sunbird/0.2+

This bug documents some search functionality that has broken in recent nightlies.

Reproducible: Always

Steps to Reproduce:
Text filtering doesn't match correctly when you use upper case search keyword(s):
1. Suppose I have several events with the string "STS" in the title.
2. a) Search for "STS".
Actual Result: No results!
2. b) Searching for "sts" 
Actual Result: Returns the expected results listing all events with "STS" in the
title.
Expected result: Step 2 a) and b) should return the same results.

Double clicking on a search result when filtering with a text string doesn't
open the correct event:
1. Perform a search with a text string filter
2. Click on one of the search results or double-click to open.
Actual Result: The wrong event is selected in the calendar or the wrong event is
opened.
Exception: If the events in the text-filtered list are in the same position in
the list as the original un-filtered list, then the correct event is opened.
(This tells me the list index is used as an index into a list of events, but
that is not sufficient when there are gaps between events in the result list
because of the filter)
Expected result: The correct event should always be selected in the calendar or
opened.

Calendar-Search result interaction is broken when text filtering is active.
1. Perform a search that returns some results.
2. Click on an event that was not returned by your search result.
Actual result: Result list is cleared, search seems to be non-functional unless
I enter a search that matches the selected event
Expected result: No events are selected in the search results, but the results
are not altered in any other way -- the search criteria has not changed.

Actual Results:  
(see above)

Expected Results:  
(See above)

(Note: These pieces of functionality worked in build 2005011112 and are broken
in 20051005.)

Comment 1

12 years ago
Bugzilla bugwriting guidelines state that multiple issues should not be
addressed in a single bug.  These problems will not be solved by the same patch,
so they should not be in the same bug.  Please re-file.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.