If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Tabbing skips over text input after clicking it

RESOLVED WORKSFORME

Status

()

Core
Keyboard: Navigation
RESOLVED WORKSFORME
12 years ago
12 years ago

People

(Reporter: mats, Assigned: Aaron Leventhal)

Tracking

({regression, testcase, top100})

Trunk
x86
Linux
regression, testcase, top100
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
Tabbing skips over text input after clicking it

STEPS TO REPRODUCE
1. load any page with a text input control
2. mouse left-click in the text input control
3. mouse left-click in the URL bar
4. TAB until you reach the text input control

ACTUAL RESULTS
Tabbing skips over the text input control and focus the next item in the
tabbing order instead. Testcase:

data:text/html,<input>

PLATFORM & BUILDS TESTED
Bug occurs in SeaMonkey 2005-10-05-03 trunk Linux

Regression window 2004-11-27-07 -- 2004-12-06-08

Comment 1

12 years ago
regressed bewteen 2004-12-01-06 and 2004-12-02-05, but there's a lot that landed
in that range.
(Assignee)

Comment 2

12 years ago
> 3. mouse left-click in the URL bar
> 4. TAB until you reach the text input control

* Tab skips over everything before the text input as well.
* This isn't specific to text inputs. Tabbing comes out of the search bar and
goes right to the next item
* IE works the same way. It's just focus memory. We start tabbing in the
document relative to where you were last in the document.

Not sure this is really a bug.
(Reporter)

Comment 3

12 years ago
So why is there a difference between these two testcases:
data:text/html,<input>
data:text/html,<button>button</button>

In the first, we focus what comes after the text input.
In the second we focus the button.
I see identical behavior on the two testcases in comment 3...

Comment 5

12 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20060512 Minefield/3.0a1

This works for me, too.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.