Bookmark Manager and Error Console toolbars should respect general toolbar settings

RESOLVED WORKSFORME

Status

()

Firefox
Toolbars and Customization
RESOLVED WORKSFORME
13 years ago
5 years ago

People

(Reporter: Andreas Wuest, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b5) Gecko/20051005 Firefox/1.4.1

Toolbars in Bookmark Manager and JavaScript Console do not behave similar to
toolbars in browser window. If e.g. using small icons and icon only toolbars in
the browser window, neither the Bookmark Manager nor the JavaScript Console
apply the same setting to their toolbars.

Reproducible: Always

Steps to Reproduce:
1. Open View -> Toolbars -> Customize... and check "Use Small Icons"
2. Open Bookmark Manager
3. Icons are still large

Actual Results:  
Neither the Bookmark Manager nor the JavaScript Console apply the toolbar
settings to their toolbars.

Expected Results:  
ALL existing toolbars should adhere to the settings made in View -> Toolbars ->
Customize...

theme: default Firefox theme
(Reporter)

Comment 1

13 years ago
Bug #190411 reports only the "small icons" facet of this bug. Furthermore it's
restricted to the Bookmark Manager, and was erroneously  assigned to component
"Bookmarks" instead of "Toolbars". Therefore I opened this bug, basically
*obsoleting* bug #190411.

Please continue discussion of the problem here instead of in #190411.
Blocks: 190411
(Reporter)

Comment 2

13 years ago
Created attachment 198677 [details]
screenshot shows toolbars other than in main browser window disrespecting general toolbar settings

Compares the Bookmark Manager toolbar with main browser window toolbars.
(Reporter)

Updated

13 years ago
OS: MacOS X → All
Hardware: Macintosh → All

Updated

13 years ago
No longer blocks: 190411

Comment 3

13 years ago
(In reply to comment #0)
> Toolbars in Bookmark Manager and JavaScript Console do not behave similar to
> toolbars in browser window. If e.g. using small icons and icon only toolbars in
> the browser window, neither the Bookmark Manager nor the JavaScript Console
> apply the same setting to their toolbars.

If you mean icons in Bookmark Manager and the JavaScript Console should depend
on the main toolbars setting, then I have to disagree.
(Reporter)

Comment 4

13 years ago
(In reply to comment #3)

> (In reply to comment #0)
> > Toolbars in Bookmark Manager and JavaScript Console do not behave similar to
> > toolbars in browser window. If e.g. using small icons and icon only toolbars in
> > the browser window, neither the Bookmark Manager nor the JavaScript Console
> > apply the same setting to their toolbars.
> 
> If you mean icons in Bookmark Manager and the JavaScript Console should depend
> on the main toolbars setting, then I have to disagree.

Well, this would be the simplest solution to the problem (called "first
solution" below). Of course it would be nice if we could set the "Use Small
Icons" and wether to use icon+text, icon, or text properties independently on
the toolbars in Bookmark Manager as well as the JavaScript Console (called
"independent solution" below).

If someone has a patch for the independent solution, we should definitely
consider it over the first solution, but if there exists only a fix deploying
the first solution, I dare to say that this would still be better than the
current situation!

Comment 5

13 years ago
Marking this as NEW because I can't find a dupe. It is too early to say whether
this bug "obseletes" bug 190411 (for bookmarks) and bug 276904 (for JS console)
or not, because that is dependant on which solution the Firefox peers prefer. I
imagine a patch emerging for one or the other would be more persuasive to them
than any arguing here. Let's try to keep the debate civil, please.

Also note bug 172517, which lumps several of these issues into one.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 6

13 years ago
(In reply to comment #5)
> Marking this as NEW because I can't find a dupe. It is too early to say whether
> this bug "obseletes" bug 190411 (for bookmarks) and bug 276904 (for JS console)
> or not, because that is dependant on which solution the Firefox peers prefer. I
> imagine a patch emerging for one or the other would be more persuasive to them
> than any arguing here. Let's try to keep the debate civil, please.
> 
> Also note bug 172517, which lumps several of these issues into one.

I think Bug 190411 depends on bug 172517 (marked so there), but this bug 190411
about the inheritance of toolbar settings and bug 190411 are orthogonal so I
agree this needs a developer review.
I don't see a reason why this is necessary.  In the main window, a minimal
config is of greater use than lesser-used utility windows.  There isn't really a
point to customization or configuration of rarely-used windows, other than as a
false economy.
(Reporter)

Comment 8

13 years ago
(In reply to comment #6)

> (In reply to comment #5)
> > Marking this as NEW because I can't find a dupe. It is too early to say whether
> > this bug "obseletes" bug 190411 (for bookmarks) and bug 276904 (for JS console)
> > or not, because that is dependant on which solution the Firefox peers prefer. I
> > imagine a patch emerging for one or the other would be more persuasive to them
> > than any arguing here. Let's try to keep the debate civil, please.
> > 
> > Also note bug 172517, which lumps several of these issues into one.
> 
> I think Bug 190411 depends on bug 172517 (marked so there), but this bug 190411
> about the inheritance of toolbar settings and bug 190411 are orthogonal so I
> agree this needs a developer review.

I see what you mean, but I think bug 172517 is not talking about different
toolbars in the sense of the toolbar in the main browser window and the toolbar
in the Bookmark Manager etc. As far as I understand but 172517, they want to be
able to have different settings for the various toolbars on the MAIN browser
window, i.e. if you create a new toolbar and in one add for example the
"previous" and "next" button, and in the other e.g. "cut", "copy" and "paste",
they want to have different settings for EACH of these toolbars. The first one
should have big icons and text, the second one small icons and no text. But they
do not consider other toolbars than those in the main browser window.

(Reporter)

Comment 9

13 years ago
(In reply to comment #7)

> I don't see a reason why this is necessary.

The reason seems to be that there are several bug reports requesting this
functionality.

Comment 10

13 years ago
gah, apologies, wrong bug changed

Updated

12 years ago
Summary: Bookmark Manager and JavaScript Console toolbars should respect general toolbar settings → Bookmark Manager and Error Console toolbars should respect general toolbar settings
It appears to me that with many changes to the theme over the years this bug no longer exists
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.