Last Comment Bug 311346 - Add directory service key for "C:\Program Files"
: Add directory service key for "C:\Program Files"
Status: RESOLVED FIXED
: fixed1.8
Product: Core
Classification: Components
Component: XPCOM (show other bugs)
: Trunk
: x86 Windows 95
: P1 normal (vote)
: mozilla1.8beta5
Assigned To: Benjamin Smedberg [:bsmedberg]
:
Mentors:
Depends on:
Blocks: 300139
  Show dependency treegraph
 
Reported: 2005-10-06 06:27 PDT by Benjamin Smedberg [:bsmedberg]
Modified: 2005-10-10 20:45 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Add dirservice key, rev. 1 (10.81 KB, patch)
2005-10-06 06:28 PDT, Benjamin Smedberg [:bsmedberg]
darin.moz: review+
asa: approval1.8rc1+
Details | Diff | Splinter Review
bustage fix (979 bytes, patch)
2005-10-10 01:43 PDT, Simon Montagu :smontagu
no flags Details | Diff | Splinter Review

Description Benjamin Smedberg [:bsmedberg] 2005-10-06 06:27:02 PDT
There is a directoryservice key that looks like it should be this, but it
actually points to "Programs" in the Start menu.
Comment 1 Benjamin Smedberg [:bsmedberg] 2005-10-06 06:28:23 PDT
Created attachment 198694 [details] [diff] [review]
Add dirservice key, rev. 1
Comment 2 Darin Fisher 2005-10-07 15:25:58 PDT
Comment on attachment 198694 [details] [diff] [review]
Add dirservice key, rev. 1

r=darin

It's a shame that these windows specific directory service keys are not
prefixed with "Win" or something like that.
Comment 3 Benjamin Smedberg [:bsmedberg] 2005-10-09 12:23:52 PDT
Fixed on trunk.
Comment 4 Benjamin Smedberg [:bsmedberg] 2005-10-09 12:24:47 PDT
Comment on attachment 198694 [details] [diff] [review]
Add dirservice key, rev. 1

I'd like this for xulrunner for the nsXULAppInstall implementation, it's very
low-risk since it's adding a new key and I'm using the same codepaths that are
already used.
Comment 5 Simon Montagu :smontagu 2005-10-10 00:30:37 PDT
This causes build bustage where CSIDL_PROGRAM_FILES is not defined, exactly as
in bug 241282 comment 22 and following
Comment 6 Benjamin Smedberg [:bsmedberg] 2005-10-10 01:35:37 PDT
smontagu, I'm traveling today and won't have checkin capabilities till this
afternoon, can you land an equivalent patch to the one in bug 241282?
Comment 7 Simon Montagu :smontagu 2005-10-10 01:43:30 PDT
Created attachment 199050 [details] [diff] [review]
bustage fix

No problem. This is the patch I made in my own tree.
Comment 8 Simon Montagu :smontagu 2005-10-10 02:16:07 PDT
Checked in the bustage fix.
Comment 9 Asa Dotzler [:asa] 2005-10-10 15:26:18 PDT
please tell us why we need this and if it could possibly have any negative
impact on our primary apps. Also, is it really windows95 only?
Comment 10 Benjamin Smedberg [:bsmedberg] 2005-10-10 15:32:52 PDT
No, this patch is all-windows, the build fix that smontagu created is for old
windows SDKs that don't define the proper constant. The risk is minimal (except
for the build bustage which was fixed) since nobody except XULRunner will be
using this key. The reason I want this patch for 1.8 is so that XULRunner knows
that windows apps belong by default in C:\Program Files (bug 300139).

Note You need to log in before you can comment on or make changes to this bug.