content of two pages, along with HTTP headers, mixed together

RESOLVED WORKSFORME

Status

()

Core
Networking: HTTP
RESOLVED WORKSFORME
13 years ago
11 years ago

People

(Reporter: Michal Seliga, Unassigned)

Tracking

1.7 Branch
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

7.24 KB, text/plain
Details
(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

i was on page http://titulky.images.o2.cz/ searching for subtitles. i downloaded
few of them. then i pressed mouse on bookmark pointing to
http://www.isternet.sk/~vus/ (in the same window, in the same tab)

now instead of content of web http://www.isternet.sk/~vus/ i received html
source which was for sure mixed between these two pages (isternet one and
subtitle one). 

complete output is attached, i am not sure how bugzilla would handle it



Reproducible: Couldn't Reproduce




i also noticed that sometimes when you are on page where subtitles are loaded
and you make refresh then it shows some headers on top of page, i am not sure if
this is problem of page or problem of firefox. but it may be related to bug i am
reporting
(Reporter)

Comment 1

13 years ago
Created attachment 198700 [details]
output i received
Created attachment 198702 [details]
output
Attachment #198700 - Attachment is obsolete: true

Comment 3

13 years ago
If this is a bug in Firefox, it's a security hole in Firefox.  If this is a bug
in a proxy server, it's probably a security hole in that proxy server.
Assignee: nobody → darin
Component: General → Networking: HTTP
Product: Firefox → Core
QA Contact: general → networking.http
Summary: invalid data shown when switching between webs → content of two pages, along with HTTP headers, mixed together
Version: unspecified → 1.7 Branch

Updated

12 years ago
Whiteboard: [sg:needinfo]
Is this an issue in a current build?
(Reporter)

Comment 5

12 years ago
i don't know,it happened only once and i couldn't reproduce it even with version i reported it in

Updated

12 years ago
Assignee: darin → nobody
Possibly the cache-collision issue fixed in bug 347852, although that was pretty consistent on the affected pages. Really not much more we can do with the information here.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
Whiteboard: [sg:needinfo]
You need to log in before you can comment on or make changes to this bug.