Camino uses a lot of CPU

RESOLVED DUPLICATE of bug 166932

Status

Camino Graveyard
General
--
major
RESOLVED DUPLICATE of bug 166932
13 years ago
13 years ago

People

(Reporter: M-Rick, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Camino uses a lot of CPU for it alone.
Simple, for 3 tabs opened it consumes 15% of the CPU while Shiira with 10 tabs
opened stays at 0% !
And it becomes worst again if a page contains Flash content.
And the longer it is used, the most is uses CPU. It as the same big failings
that its brother Firefox has ...

What a pity, I hope it will be possible to correct this.

Reproducible: Always
(Assignee)

Comment 1

13 years ago
please try 1.0alpha1 and let us know if you have the same problems. also, can 
you give us a reproducable test case?
(Reporter)

Comment 2

13 years ago
When I use the alpha it does it more than with my actual nightly build.

Comment 3

13 years ago
I'm closing this bug due to it's incredible vagueness. Please do reopen it if
you or anybody else has more proof.

Basically we could just say that it's logical that we use more cpu then other
browsers that use webkit. We render using the CPU and they use the GPU (graphics
card).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
(Reporter)

Comment 4

13 years ago
I know where the problem comes from !

In fact the responsibles ot this are all these sites full of advertsiement !!!
Because when Camino becomes to very slow and use a lot of CPU, i make a link of
all teh pages, and then opened them in Shiira, same problem !
Then I opened them in Firefox, no problem but all the ads are already blocked
with adblock !

So in fact Camino needs a real improvement in ads blocker.

So you can attach this bug to a bug that is related to adblocking.
(Reporter)

Comment 5

13 years ago
On Apple site http://www.apple.com/ when there is the new iPod animation, Camino
uses up to 35 % of the CPU and my iMac G5 is running very fast while i don't
hear it on normal time.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
30% CPU is not bad for pages with animated elements, given our known bugs and limitations of QD.

*** This bug has been marked as a duplicate of 166932 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.