Closed Bug 311382 Opened 15 years ago Closed 12 years ago

reloading modified local file yields "File not found"

Categories

(Firefox :: General, defect)

PowerPC
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 322686

People

(Reporter: enolte, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4

Reloading a modified local file returns the "Problem loading page" (title) /
"File not found" (body) instead of the modified file.

Reproducible: Always

Steps to Reproduce:
1. Create /tmp/x.html containing the following:
   <html> <body> this is file 1 </body> </html>
2. View file:///tmp/x.html in Firefox
3. Edit /tmp/x.html (with vi) so that it now contains
   <html> <body> this is file 2 </body> </html>
4. Press the refresh button

Actual Results:  
The following is displayed:

File not found

      

      
      
      

      
        
        

          

Firefox can't find the file at /Users/enolte/Documents/HomePage/mac.html.

        


        
        


    *   Check the file name for capitalization or other typing errors.

    *   Check to see if the file was moved, renamed or deleted.

Try Again

Expected Results:  
A page with the following body: "this is file 2"

This problem only seems to happen when the file is edited with vi (not TextEdit
or emacs).  I think this is a Firefox problem rather than a vi problem because
after I exit vi, I can 'ls' and 'cat' x.html.  The file definitely exists with
the correct filename and the modified content.
This problem does not occur with Safari 2.0.1 or Opera 8.5.
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b5) Gecko/20051006
Firefox/1.4.1 ID:2005100604

WFM (on Win)
Hallo,

I have a similar problem.

I've load a jpg-(file:///path/image.jpg) or png-file in firefox2.0.0.4 and the version of today.
The jpg are displayed correctly. 
Then, I change (create an new file with the same name by batik) the jpg/png and reload the file with ctrl + enter or shift + enter. There is the problem: the url was alter into http://www.file///path/image.jpg, so that the file couldn't be found. 
If I reload this image by the reload-button, everything is ok and the jpg/png are displayed correctly. 
for additional information: I use linux
I see the same behavior.  Works fine in ff2, "File not found" in trunk.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Dup of bug 322686?
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 322686
You need to log in before you can comment on or make changes to this bug.