Incorrect render with a <div> containing a <blockquote> containning a <pre>

RESOLVED INVALID

Status

()

Core
Layout
RESOLVED INVALID
12 years ago
12 years ago

People

(Reporter: François Gagné, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1

A string in the <blockquote><pre> is displayed outisde the div containning it.

Reproducible: Always

Steps to Reproduce:
1.Open http://www.tenletters.com/rhahn/Internet/Web/utf8.html
2.Serach for '<meta http-equiv="content-type" content="text/html;
charset=utf-8">' part.
Actual Results:  
The text is draw outside the containning div.

Comment 1

12 years ago
It looks like the correct rendering to me: the DIV is fixed width, so doesn't
expand to fit its content.

Comment 2

12 years ago
Comment 1 is correct; the div and its contents are restricted to a fixed width,
but since <pre> doesn't have line breaks unless you tell it to, its content
doesn't fit in that width. The <pre> (by default) has overflow:visible, so the
content that doesn't fit is still shown.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.