uninstall doesn't remove all files (software update files are left behind)

RESOLVED FIXED in mozilla1.8final

Status

()

Toolkit
Application Update
P1
normal
RESOLVED FIXED
13 years ago
10 years ago

People

(Reporter: Darin Fisher, Assigned: Benjamin Smedberg)

Tracking

({fixed1.8, regression})

Trunk
mozilla1.8final
x86
Windows XP
fixed1.8, regression
Points:
---
Bug Flags:
blocking1.8rc1 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: has patch, needs review darin)

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
uninstall doesn't remove all files (software update files are left behind)

these files in particular:

  active-update.xml
  updates.xml
  updates/*

we should probably ship with "empty" versions of these files so that the
installer will know about them and record their existance in the
install_wizard1.log file.

I guess this is a regression since it prevents us from cleanly uninstalling.
(Reporter)

Updated

13 years ago
Status: NEW → ASSIGNED
Flags: blocking1.8rc1?
Target Milestone: --- → Firefox1.5
> we should probably ship with "empty" versions of these files so that the
> installer will know about them and record their existance

For the generated files you listed the preferred solution would be to add some
logComment lines of the right format to the initial install. You don't need to
ship actual empty versions. see
http://lxr.mozilla.org/mozilla/source/browser/installer/windows/browser.jst#129
(which appears to be out of date).

But that would be a temporary band-aide. Eventually we will software update to
Firefox 2.0 and there's no way to know in advance what new components might be
added. I think we *also* need to build logic into the updater that if we "add" a
file rather than replacing one that already exists then we have to add an entry
to one of the install_wizardx.log files. Maybe this bit should be spun into a
different bug.

Updated

13 years ago
Flags: blocking1.8rc1? → blocking1.8rc1+

Comment 2

13 years ago
Trying to load balance some here. from darin -> bsmedberg. 
Assignee: darin → benjamin
Status: ASSIGNED → NEW
(Reporter)

Comment 3

13 years ago
> I think we *also* need to build logic into the updater that if we "add" a
> file rather than replacing one that already exists then we have to add an entry
> to one of the install_wizardx.log files.

dveditz: See nsPostUpdateWin.js.  It already knows how to add log comments to
the install_wizard log file when new files are added.  The problem is that the
updater cannot record entries about files that are dynamically generated because
it only knows about files that it adds.
(Assignee)

Comment 4

13 years ago
Created attachment 199258 [details] [diff] [review]
Add logComment
Attachment #199258 - Flags: review?(darin)
(Assignee)

Updated

13 years ago
Priority: -- → P1
Whiteboard: has patch, needs review darin
(Reporter)

Comment 5

13 years ago
Comment on attachment 199258 [details] [diff] [review]
Add logComment

This looks good to me.	r=darin
Attachment #199258 - Flags: review?(darin) → review+
(Assignee)

Comment 6

13 years ago
Fixed on trunk
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
(Assignee)

Updated

13 years ago
Attachment #199258 - Flags: approval1.8rc1?

Comment 7

13 years ago
Comment on attachment 199258 [details] [diff] [review]
Add logComment

approving the log comment.
Attachment #199258 - Flags: approval1.8rc1? → approval1.8rc1+
(Assignee)

Comment 8

13 years ago
fixed on 1.8 branch
Keywords: fixed1.8
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.