Mouse clicking within a blockquote causes a focus ring to appear

RESOLVED WORKSFORME

Status

()

Core
Event Handling
RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: Thomas Rutter, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051004 Firefox/1.4.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051004 Firefox/1.4.1

Clicking with the left, middle or right mouse button within a blockquote element
causes a focus ring to appear, where previously it didn't.

I believe this regression occurred some time between the 20051004 and 20051006
(inclusive) 1.8 branch builds of firefox.

Note that the blockquote element can't be 'focused' by tabbing to it.

Reproducible: Always

Steps to Reproduce:
1. Load testcase
2. Click somewhere within the blockquote element (seen here as an search result
indented on the left hand side)
Actual Results:  
Focus ring (a 1px dotted rectangle) appears around the boundary of the
blockquote element.

Expected Results:  
No focus ring.

Other testcase:
http://www.boingboing.net/2005/10/06/guy_who_was_busted_f.html

Click on the blockquote within the article.

Note: I wasn't sure what component to file this bug in.
(Reporter)

Comment 1

13 years ago
Unable to reproduce bug in build 20051006 - must have been short-lived.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.