sourceforge.net - optusnet mirror sends .jar file as text/plain

RESOLVED FIXED

Status

RESOLVED FIXED
13 years ago
4 years ago

People

(Reporter: richard.rowe, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

the download of the file starts directly, outputting text to the screen (and
this is a 24M file).  The default option set (save to disk) is not activated.
Happens every time.

I can't find anywhere an option to run these files. It still happened after I
removed the 'run java' option in the advanced tools.

IE (whatever version I still have ... ) stops the file from downloading then
after manual intervention offers options including 'save to disk'

Reproducible: Always

Steps to Reproduce:
1.click on link in sourceforge
2.wait while sourceforge sets up
3.sit back and watch ...

Actual Results:  
exhibits opening lines of java program as text

Expected Results:  
I really wanted to download the package to disk to install it ...

Comment 1

13 years ago
I tried a bunch of mirrors.  Most of them triggered the open/save dialog, but
the choosing the Optusnet mirror resulted in the bad behavior described by the
reporter.  This happens because the Optusnet mirror sends the file as text/plain.

I wonder why Sourceforge doesn't require its mirrors to use the correct mime
types, and why it doesn't check that its mirrors use the correct mime type.

-> Tech Evang
Assignee: nobody → english-us
Status: UNCONFIRMED → NEW
Component: Download Manager → English US
Ever confirmed: true
Product: Firefox → Tech Evangelism
QA Contact: download.manager → english-us
Summary: presents download as text on screen, does not offer 'save to disk' options → sourceforge.net - optusnet mirror sends .jar file as text/plain
looks fixed
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.