after long usage (4-8 hours) speed of rendering animated elements slows down to almost freezing

VERIFIED INCOMPLETE

Status

()

Firefox
General
VERIFIED INCOMPLETE
12 years ago
7 years ago

People

(Reporter: Vladimir Lazarenko, Unassigned)

Tracking

({perf})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; Maxthon)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

After a few hours of using mozilla firefox, the speed of rendering animated 
elements (animated gifs, progress bars in firefox and even thunderbird [they 
use the same engine?]) becomes very slow. LOTS slower than normal. You can 
also see that the animation is not smooth. A few frames would slow down, the 
following frames would go with 10x speed. Restart of the application does not 
help, only restart of the whole PC. I'd suppose it's some sort of memory leak, 
but unfortunately I can't prove it by looking in the code. 

For instance, as an example, the url loading progress bar's movement would be 
very distorted after a while, or Thunderbird's notification of incoming mail 
would also slow down to taking 50 seconds tho show up and disappear with 
distorted motion. 

I tried this on a totally clean PC, with freshly installed XP, so that I'm 
sure no software can affect that.

PC itself is a dual-core amd 3800+ with 1.5G ram. I've seen it happening on 
other machines as well, actually, same behavior occurs on my laptop, on some 
machines of my colleagues at work and so on, so the problem is indeed not only 
limited to my PC.


Reproducible: Always

Steps to Reproduce:
1. Open up mozilla
2. Browse here and there for a couple of hours (or just use the same mozilla 
session for a few days)
3. Open up some page with animated gif in it, and look at the motion

Actual Results:  
The gif's motion would be distorted.

Expected Results:  
The gif's motion should be smooth.

Comment 1

12 years ago
Does it also occur with the latest beta release?
http://www.mozilla.org/projects/firefox/
(Reporter)

Comment 2

12 years ago
Yes, I've downloaded 1.5 beta a few days ago, same behaviour. Then 1.0.7 was
released, I tried 1.0.7 - same stuff.

I know it may sound very vague... But I can't really describe it better :) Can
try to arrange a demo though if it would be necessary. :)

Comment 3

12 years ago
(In reply to comment #2)
> I know it may sound very vague... But I can't really describe it better :) Can
> try to arrange a demo though if it would be necessary. :)

A testcase would always help

(Reporter)

Comment 4

12 years ago
Any ideas if I could have enabled some debugging or use something to be able to
provide more detailed info? 

Comment 5

12 years ago
Need a testcase.
(Reporter)

Comment 6

12 years ago
Here, a couple of gifs which slowdown for me... As soon as I will find some
more, i'll place them at the same location.

http://home.lazarenko.net/311471/


The same slowdown comes also for progress bar of thunderbird, while receiving
the mail, the green sectioned one.

Comment 7

11 years ago
http://home.lazarenko.net/311471/ is dead.
no URL for bug, so => INCOMPLETE
if you have a new testcase please reopen the bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Keywords: perf
Resolution: --- → INCOMPLETE

Updated

7 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.