Delaying software update by pressing "Later" doesn't give user proper feedback when dialog reappears

RESOLVED FIXED in Thunderbird1.1

Status

Thunderbird
General
RESOLVED FIXED
13 years ago
13 years ago

People

(Reporter: marcia, Assigned: Scott MacGregor)

Tracking

({fixed1.8})

unspecified
Thunderbird1.1
PowerPC
Mac OS X
fixed1.8
Bug Flags:
blocking1.8rc1 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Seen using version 1.5 Beta 2 (20051006).  I have seen this consistently for the
past 3 days on Tbird side.  Not seen on the Firefox side.

STR:

1.  Turn on Auto update
2.  Receive notification of an update.
3.  Click later
4.  Go to Help meno to "Resume Downloading" Thunderbird
5.  Receive the attached screenshot
6.  Restart Thunderbird and the update has downloaded, but you would never no it
by the screen that you get.
(Reporter)

Comment 1

13 years ago
Created attachment 198811 [details]
Screenshot of Thunderbird Update Window
(Assignee)

Comment 2

13 years ago
I wonder if this is the same JS error reported in Bug 308367
(Reporter)

Comment 3

13 years ago
Scott: I will check the JS console when I get the Tbird download tomorrow, but
this is happening to me consistently every day and is definitely a bad user
experience.

(In reply to comment #2)
> I wonder if this is the same JS error reported in Bug 308367

(Reporter)

Comment 4

13 years ago
Here are the first three info points I see in the JS Console today, when I click
on Resume downloading Tbird - there are more than this and I don't get the error
referenced in Bug 308367 . I see that Bug 308367 has been fixed, so hopefully
that will resolve the problem in this bug.


Datasource: Update Started

Datasource: Addon Update Started: {19503e42-ca3c-4c27-b1e2-9cdb2170ee34}

RDFItemUpdater:checkForUpdates sending a request to server for:
http://software.informaction.com/mozupd/?item_id={19503e42-ca3c-4c27-b1e2-9cdb2170ee34}&item_version=0.5.9.4&app_id={3550f703-e582-4d05-9a08-453d09bdfdc6}&app_version=1.4.1,
item = ({id:"{19503e42-ca3c-4c27-b1e2-9cdb2170ee34}", version:"0.5.9.4",
installLocationKey:"app-profile", minAppVersion:"1.0", maxAppVersion:"1.0+",
name:"FlashGot", xpiURL:"none", xpiHash:"",
iconURL:"chrome://mozapps/skin/xpinstall/xpinstallItemGeneric.png",
updateRDF:"http://software.informaction.com/mozupd/?item_id=%ITEM_ID%&item_version=%ITEM_VERSION%&app_id=%APP_ID%&app_version=%APP_VERSION%",
type:2})
(Reporter)

Comment 5

13 years ago
Today's Tbird build is still exhibiting this behavior.  The menu item has
changed to say "Apply update now", but the dialog does not show you the proper
status - it is the same as the screenshot that is attached to this bug.

Nominating for 1.5, this is a bad user experience.
Flags: blocking1.8rc1?
(Reporter)

Updated

13 years ago
Summary: Delaying software update by pressing "Later" hangs Thunderbird → Delaying software update by pressing "Later" doesn't give user proper feedback when dialog reappears
(Assignee)

Comment 6

13 years ago
I was just able to reproduce this on windows too!
(Assignee)

Comment 7

13 years ago
Looks like changes were made to Firefox that never got ported to Thunderbird.

Patch coming up.
(Assignee)

Updated

13 years ago
Status: NEW → ASSIGNED
Flags: blocking1.8rc1? → blocking1.8rc1+
Target Milestone: --- → Thunderbird1.1
(Assignee)

Comment 8

13 years ago
Created attachment 199348 [details] [diff] [review]
port firefox changes to fix this

this should do the trick. These changes were made to Firefox a while ago but
never ported to thunderbird.
(Assignee)

Updated

13 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Keywords: fixed1.8
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.