During period between a version release and an automatic update becomes available on Software Update, a manual check should find the update

VERIFIED WONTFIX

Status

()

Toolkit
Application Update
--
enhancement
VERIFIED WONTFIX
13 years ago
10 years ago

People

(Reporter: tyl2, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4

Currently, there is a delay between the time a new version of Firefox is
released and when an automatic update becomes available on Software Update. To
help test the update component and further reduce the number of whole downloads,
I propose the following.

If a user clicks Help->Check for Updates, a dialog comes up stating the need to
lighten server load in the first few days of a release and asking the user if
she still wants to continue, defaulting to No. If she clicks Yes, she'll start a
manual update and will find any bugs associated with it, if that ever occurs.
For users who wait for Firefox to update itself, there's no change -- they'll
wait a few more days as they do now.

Reproducible: Always

Steps to Reproduce:
1. During the first few days of a release (e.g., Fx 1.5b2 was released last
night), click Help->Check for Updates.
Actual Results:  
No update is found, the user is told.

Expected Results:  
An update is found, but the user is encouraged to wait for auto-update.
(Reporter)

Comment 1

13 years ago
Sorry, but I forgot to mention that this improvement can/should be ported to
other products like Thunderbird and Camino as well, but I won't file bugs for
those as I assume if this bug is fixed, the others will as well.

Comment 2

13 years ago
I think this solution is overkill.  In the future, updates will simply be
available through the update service sooner since that is how most users will
get the "next" version of Firefox.  Since we are in beta right now, we are still
taking baby steps ;)

You'll find that once the update is made available that Firefox will not notice
the update right away anyways.  It has a built-in timer that causes it to take
about a day to notice an update.  There is plenty of randomness thrown in to
ease the load on the mozilla.org servers.  During this time, however, it will be
possible to start a manual update.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WONTFIX

Comment 3

13 years ago
Well, there's a better (IMHO) solution well known from eg Sourceforge download
services or Fedora updates. Just a *random first choice* of official mirror
download site. Why not to follow this idea in Mozillas updates? Of course -
there must be official mirrors list downloaded first from mozilla.org. This is a
great way to reduce the main server load. And still the hasty user can -
manually - set the favorite update site to mozilla.org. Think it's easier and
more "firefox spread"ing way ;-)

The "random first choice" sollution is great to gain users that need good and
safe way of updating their software whithout any worry about it. For now they
still use IE with autoupdates turned on. And - unfortunatelly - they are happy
about it.

Comment 4

13 years ago
Server load isn't the problem.  Ordinarily, releases will be made available via
the update service at release time.

Comment 5

13 years ago
Who "resolved" this bug as WONTFIX? And Why? So, I am hereby threatening to
reopen it, in case nobody answers that, since a WONTFIX without explaination is
most unacceptable.

PS: Commenter #3, your "better solution" is totally unnecessary as the "update
server" is in fact most certainly not one, but a group of servers (and if it is
not, it should be in the future), load-balanced via DNS. The SourceForge
approach is actually a rather poor (or at least, a very geeky) solution, and
especially not suitable for automated process.

Comment 6

13 years ago
And by "reopen", I mean "re-enter", as I currently have no way to change the
"WONTFIX" status as longer.

Comment 7

13 years ago
Henry, don't threaten module owners, it will get your bugzilla account revoked.
Status: RESOLVED → VERIFIED
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.