Flash Player should not call ::SetFocus(0) in the click handler when wmode=opaque / Flash links don't work. if it has wmode=opaque

VERIFIED FIXED

Status

defect
VERIFIED FIXED
14 years ago
4 years ago

People

(Reporter: emk, Assigned: masayuki)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: This bug is fixed with next major release(9)., URL)

(Reporter)

Description

14 years ago
This is splitted from bug 310174.
Steps to reproduce:
1. Load the testcase (see URL field).
2. Click on the Flash movie.
Actual result:
Everytime you click, ::SetFocus(0) will be called from Flash Player and extra
blur event will occur.
Expected result:
Blur event should not occur.

This is a Player problem because this occurs no matter what swf you use.
If you remove wmode=opaque parameter, the problem will disapper and you will see
::SetFocus(plug-in's hwnd) is called instead.
I guess that Flash Player trys to set focus to itself even if windowless mode is
used (that is, there is no plug-in's hwnd).
We can't fix bug 310174 until this problem is solved.
(Reporter)

Updated

14 years ago
Blocks: 313230
*** Bug 313230 has been marked as a duplicate of this bug. ***
Summary: Flash Player should not call ::SetFocus(0) in the click handler when wmode=opaque → Flash Player should not call ::SetFocus(0) in the click handler when wmode=opaque / Flash links don't work. if it has wmode=opaque
I contanted to Michelle Sintov.
Assignee: english-us → masayuki

Comment 3

14 years ago
I have fixed this in the Flash Player. As you guessed, upon clicking the Flash Player text area in this test case, the Flash Player will respond to the mouse down event by calling SetFocus(0). This has been fixed and will be available in the next major release of Flash (Flash Player 8.5).

With this fixed version of the Flash Player, when you click the Flash text field, only "onfocus" will appear in the leftmost box of the test case. In addition, the www.fox.com page now correctly processes the mouse click when you click on Shows in Deer Park Alpha 2.

Shall we set the Assigned to me and set the bug to Fixed?
Thank you.

I'm marking to fixed.
After released 8.5, we will mark to verified.
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
Whiteboard: This bug is fixed with next major release(8.5).
(In reply to comment #3)
> I have fixed this in the Flash Player. As you guessed, upon clicking the Flash
> Player text area in this test case, the Flash Player will respond to the mouse
> down event by calling SetFocus(0). This has been fixed and will be available in
> the next major release of Flash (Flash Player 8.5).
> 
> With this fixed version of the Flash Player, when you click the Flash text
> field, only "onfocus" will appear in the leftmost box of the test case. In
> addition, the www.fox.com page now correctly processes the mouse click when you
> click on Shows in Deer Park Alpha 2.
> 
> Shall we set the Assigned to me and set the bug to Fixed?

Is there an ETA for Flash Player 8.5?  Currently, in trunk builds, Flash is next to useless, since many sites use wmode=opaque (Fox.com is one such site). 

Comment 6

14 years ago
Flash Player 8.5 will be released in the first half of 2006. Sorry I can't be more specific.

Comment 7

14 years ago
is this bug the cause of what I see at:
http://gemal.dk/test/flash.htm
Nothing happens when I click on fx Musik. In IE I go to the musik site when I click Musik
*** Bug 314604 has been marked as a duplicate of this bug. ***

Comment 9

14 years ago
(In reply to comment #6)
> Flash Player 8.5 will be released in the first half of 2006. Sorry I can't be
> more specific.
> 

no chance for a Flash Player version 8.0.23.0 with the fix in?

Comment 10

14 years ago
*** Bug 315019 has been marked as a duplicate of this bug. ***

Comment 11

14 years ago
(In reply to comment #7)
> is this bug the cause of what I see at:
> http://gemal.dk/test/flash.htm
> Nothing happens when I click on fx Musik. In IE I go to the musik site when I
> click Musik
> 

I found a really really weird way out of this bug.
if you go to the site you'll see that you cant click on any of the menuitems. but if I first rightclick and then left click on the menuitems it works!

We're still sure this is a Flash bug rite?

Comment 12

14 years ago
not sure this is fixed. please read:

https://bugzilla.mozilla.org/show_bug.cgi?id=311622#c11
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
See comment 3. This is fixed on Flash Player 8.5.
We don't use the version. But this is fixed.(not verified)
If you can reproduce the problem with Flash Player 8.5, you should reopen this bug.
But otherwise, DONT REOPEN THIS BUG.
Status: REOPENED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → FIXED

Comment 14

14 years ago
using 8.5 b133 https://bugzilla.mozilla.org/show_bug.cgi?id=311622#c11 is still an issue.

got flash player 8.5 from http://www.macromedia.com/cfusion/entitlement/index.cfm?e=labs
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 15

14 years ago
Please observe timestamp of b133.
It was made at 14 October before Michelle report this fix.
You should wait a newer beta Plater.
Status: REOPENED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → FIXED
*** Bug 317256 has been marked as a duplicate of this bug. ***
*** Bug 317269 has been marked as a duplicate of this bug. ***

Comment 18

14 years ago
Note: Due to bug 310174 this affects only Trunk builds (SM 1.5a/FF 1.6a), but not 1.8 Branch builds (SM 1.0/FF 1.5) or 1.7 Branch builds (Moz 1.7/FF 1.0) with Flash 7.x/8.0.x.
*** Bug 320253 has been marked as a duplicate of this bug. ***
*** Bug 323432 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 21

14 years ago
WFM using Flash Player 8.5 a212 from http://labs.macromedia.com/
-> v.
Status: RESOLVED → VERIFIED
*** Bug 326965 has been marked as a duplicate of this bug. ***
*** Bug 327154 has been marked as a duplicate of this bug. ***
*** Bug 327213 has been marked as a duplicate of this bug. ***
Just wondering about the impacted platforms : 
Flash Player 8.5 doesn't exist in beta for Linux, it is only available for Windows  and OSX.
I've been experiencing the same issues with Flash Player 6 and Mozilla/5.0 (Windows; U; Windows NT 5.0; fr-FR; rv:1.9a1) Gecko/20060228 SeaMonkey/1.5a (and wmode=transparent actually)
Then I would suspect a fix to introduce a regression (from the point of view of the end user who doesn't upgrade its Flash Player (or who can't since it isn't available on its platform))
Couldn't the fix wait for Flash Player being available on its platform ? or the fix not being applied on platforms where the player isn't available ?
Or ... ? any suggestion

Comment 26

13 years ago
This bug is written for Win only, and the fix is also Win only.

Comment 27

13 years ago
Bug egsists on WinXP Pro SP2, so...
*** Bug 340550 has been marked as a duplicate of this bug. ***
Whiteboard: This bug is fixed with next major release(8.5). → This bug is fixed with next major release(9).
*** Bug 345453 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 30

13 years ago
*** Bug 345669 has been marked as a duplicate of this bug. ***
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.