Excessive use of operative memory

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
12 years ago
11 years ago

People

(Reporter: didaio, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1

The the browser is longer open, the it is more than memory uses. In an hour the
volume of used memory exceeds 90 Mb.
It occurs under any conditions.

Reproducible: Always

Steps to Reproduce:

Comment 1

12 years ago
How about providing any url where this happens?
(Reporter)

Comment 2

12 years ago
I have written, that it occurs irrespective of pages which are opened.

Comment 3

12 years ago
Does this also happends in safe mode? http://kb.mozillazine.org/Safe_mode
(Reporter)

Comment 4

12 years ago
Yes. It happened in safe mode.
More Memory used when I go to Gmail, Google Reader.

Comment 5

12 years ago
WFM.
I think I saw something a bit like this earlier in Bug 311645. 
Have you tried using a new profile?
(Reporter)

Comment 6

12 years ago
I uninstall Firefox, delete all files, delete all entries in registry and
install again.
I have this problem.

Comment 7

12 years ago
It's also WFM for me. Branch build 20051007, win xp

Did you start Firefox with firefox.exe -p to create a new profile?
(Reporter)

Comment 8

12 years ago
No.
But for why if I have this problem after new installation?

Comment 9

12 years ago
(In reply to comment #8)
> No.
> But for why if I have this problem after new installation?

You didn't h ave this problem before?
(Reporter)

Comment 10

12 years ago
Again.
I have Firefox 1.0.6. Uninstall it. Remove all files. Remove all entries from
registry.
Install Firefox 1.5 Beta 1. And see this problem.
After installing Beta 2 I have this problem too.

Comment 11

12 years ago
Try comment 7 please
(Reporter)

Comment 12

12 years ago
When I start Firefox with "-p", How I can returh old profile after creating new?

Comment 13

12 years ago
1. start firefox.exe -p
2. create new profile, name it, start firefox
3. test again, does it work better?
4. to go back to the old profile, start fireofx again with -p and select your
old profile
(Reporter)

Comment 14

12 years ago
I have this problem after creating new profile too.
After start I have 18 Mb memory. After 10 minutes I have 32 940 Kb.
I visited to Gmail, LiveJournal, mozilla.org.
I don't make any changes in options after creating new profile.

Comment 15

12 years ago
I am also in that memory range when surfing around after a while. Same with IE 6.
(Reporter)

Comment 16

12 years ago
I use it only 10 minutes.
I want my options and extensions for work and can't test more then this time.
When  I go to sleep I leave opened Firefox (new profile).

Firefox Developers speak: Firefox use less memory than IE

Comment 17

12 years ago
(In reply to comment #16)
> Firefox Developers speak: Firefox use less memory than IE

I hope this is not a statement you got from this bug report, since I am no
Firefox Developer

(Reporter)

Comment 18

12 years ago
Ok. I use new profile and memory using is normal.
What is this? And how I can fix it for my real profile? TY.

Comment 19

12 years ago
>>I use new profile and memory using is normal.

Sounds like it could possibly be an extention or theme causing your problem with
memory then. 
(Reporter)

Comment 20

12 years ago
As I say, I use only Greasemonkey 0.6.2 and last version of Flashgot. I haven't
any themes.

Comment 21

12 years ago
(In reply to comment #20)
> As I say, I use only Greasemonkey 0.6.2 and last version of Flashgot. I haven't
> any themes.

So it could be one of these extensions causing the memory leak. You could (if
you want) install each one of them in your new profile, one at the time, to see
which one is causing the leak
(Reporter)

Comment 22

12 years ago
My friends who have these exts don't have this problem.

I have "Remember last visited pages in _999_ days". It can be problem?

Comment 23

12 years ago
(In reply to comment #22)
> I have "Remember last visited pages in _999_ days". It can be problem?

Could be yes,set it 9 days and clear the browsing history, does it help?

(Reporter)

Comment 24

12 years ago
I change to 7 days.
In some case it fixed problem. For now I have ~59 Mb memory used by Firefox.
It's normal or not?

Comment 25

12 years ago
Depens on what sites you use, but i usually land on 40-50 something
(Reporter)

Comment 26

12 years ago
For now I have 85 Mb memory used.
I visited to:
mail.google.com
livejournal.com
dirty.ru
uk.wikipedia.org
bugzila.mozilla.org

Comment 27

12 years ago
Greasemonkey (or at least some Greasemonkey scripts) caused quite a bit of leaking due to bug 241518.

didaio@gmail.com, is Firefox's memory usage significantly better for you if you use a trunk build (which includes a fix for bug 241518) instead of Firefox 1.5?
(Reporter)

Comment 28

12 years ago
I don't know. I don't like to use trunk builds :)
Sorry.

Comment 29

11 years ago
Thanks for the report, but there is not enough here for the bug to be resolved - a report needs several aspects of good reporting documented at http://www.mozilla.org/quality/bug-writing-guidelines.html to move forward, including Reproducible and Specific (as in a list of steps numbered 1, 2, 3, ...)

For general assistance and help with reporting a bug you might visit forums.mozillazine.org

There are bugs with status of new or assigned for many types of memory issues, from java to gmail. Before searching bugzilla to find a good match it will be helpful if you test and eliminate all issues except the one specific problem activity, and read the bug before commenting, if you choose to do so.
Severity: critical → normal
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.