select element in table cell expands indefinitely when used, when CSS height is set to 100% but table row height is not set.

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: Dean Trower, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322; InfoPath.1)
Build Identifier: Firefox 1.0.7

If you have a <SELECT> inside a table cell, and the <SELECT> has CSS style 
width:100%;height:100%, but the table row has no set height, then certain user 
or script manipulations of the SELECT (e.g. selecting a new option; 
toggling 'disabled' status) will cause the <SELECT> and the table cell 
containing it to grow horizontally (by the width of the drop-down arrow, I 
think).  This occurs indefinitely (unbounded growth).

*** It happens even if the table cell has a constrained width!!! ***

Note that this is very similar to bug #70998, but has not been fixed!

Reproducible: Always

Steps to Reproduce:
1. Load the test case (attached)
2. Try selecting a different option in the drop-down
3. Try clicking the button a few times

Actual Results:  
The combo-box expands horizontally with each action

Expected Results:  
no expansion, duh!
(Reporter)

Comment 1

13 years ago
Created attachment 198904 [details]
test case
Please test with the Firefox1.5b2 or the nightly trunk build and test if you can
still see the bug.
Testcase WFM

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051007
Firefox/1.4.1 ID:2005100705

Comment 4

13 years ago
WFM Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1)
Gecko/20051007 Firefox/1.6a1 (debug)
(Reporter)

Comment 5

13 years ago
I'm just a regular user, not a developer, reporting a bug in the production 
version.  If the bug is fixed in the latest beta version, then great!
(In reply to comment #5)
> I'm just a regular user, not a developer, reporting a bug in the production 
> version.  If the bug is fixed in the latest beta version, then great!
Ok, marking WFM then. Dean, reporting bugs with that version1.0.7 has become
nearly useless, since a lot of bugs have been fixed since then (and other bugs
have appeared).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.