Closed Bug 311642 Opened 16 years ago Closed 9 years ago

Newsgroups: Confusing naming/naming inconsistency for kill, ignore, delete

Categories

(Thunderbird :: Mail Window Front End, enhancement)

x86
Windows 2000
enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: gudmundpublic, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7
Build Identifier: Thunderbird version 1.0 (20041206)

The naming of the actions "kill" (as in pressing K to kill a thread in e. g.
newsgroups), "ignore" (that does the same) and "delete" (which can be used to
"killfile") in newsgroup message filtering, confuses users, as can be seen from
the many recurring questions about these features in the Thunderbird newsgroup. 

It seems to cause difficulties even for more seasoned users.

The most inconsistent and misleading naming for the phenomenon is "Delete" in
the lower pane of message filter settings, since in NG's, deleting normally
refers to deleting a message on the NG server - something only the original
poster or an admin can do in many/most NG's. Not the same as a local action.

Consistently using "ignore" throughout would probably be less confusing. "Ignore
thread" (later hopefully "Ignore subthread" too), "Ignore message", "Ignore
sender" or "Ignore on filter selection". Plus "Kill" and "Killfile" in help
index pointing to the parts about "Ignore". 

Possibly, "Delete message header" could be used for NG's in the message filter
dialogue instead of the "ignore" line, and "Delete message on server" for
e-mail, although it would break the consistency "ignore" might give. Ignore also
has the advantage of implicating in itself that the actions take place locally.

Reproducible: Always



Expected Results:  
It should use some consistent naming convention for events as viewed and
perceived from the user side, to avoid confusion.

This can probably be done without being inconsistent towards the underlying
technology.
QA Contact: front-end
Assignee: mscott → nobody
I'm not a news expert, but from what I can see on TB17.0.6/WinXP, we mostly have what comment 0 requests:

- From main three pane, view newsgroup
- message > Ignore Thread (K) | Ignore Subthread (Shift+K)
- Edit > Delete msg and it's no counterpart on msg context menu are disabled, and Ignore options are not offered (which looks like another RFE)

So I'll close this wfm.

Feel free to reopen if you feel otherwise.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → WORKSFORME
Summary: Confusing naming/naming inconsistency for kill, ignore, delete → Newsgroups: Confusing naming/naming inconsistency for kill, ignore, delete
You need to log in before you can comment on or make changes to this bug.