right clicking to bring up the context menu increases memory

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
13 years ago
12 years ago

People

(Reporter: user_2_2_2, Unassigned)

Tracking

1.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051007 Firefox/1.4.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051007 Firefox/1.4.1

The memory allocation of Firefox, Mozilla and Gecko itself, is never handled
properly. For example, keep right clicking to bring up the context menu, or keep
opening and closing the "Options/Preferences" dialog. If you keep doing the
above actions for many times, you'll notice that the memory usage of Firefox
keeps increasing even though there are almost no changes in the context menus or
the "Options/Prefrences" dialog.

Reproducible: Always



Expected Results:  
Since there are almost no changes in the context menus or the
"Options/Preferences" dialog, the memory usage of Firefox should not increase so
much, even if the actions have been done many times.

Comment 1

13 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051005
Firefox/1.4.1

WFM, try entering safe-mode and see if it still does it. 
(Reporter)

Comment 2

13 years ago
[WFM, try entering safe-mode and see if it still does it.]

Yes.

Comment 3

13 years ago
When firefox (Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8) Gecko/20051111 Firefox/1.5 )and older versions
start up with blank startup page and installed with general default installation
it starts up with 20,000k.
When I open a few pages and a streaming url (KOGO.com) it increased to 40,000k.
After closing all tabs it still retains 40,000k.

Comment 4

13 years ago
Created attachment 217148 [details]
memory usage diagram under win2000

hello,
i have the same problem every day and today, i make a protocol of memory usage over some our.

in the time, i open some windows and tabs and close them. at the time, the program is terminated, the same count of windows and tabs are open as at the begin.

the memory usage starts with 100 mb (if program ist started, less then 50 mb) and end with over 400 mb of memory usage.

to get a continus grow of the memory, i load a page from local nagios network manager which is reload every 90 second.

i have the same problem with microsoft internet explorer, but not with the same page. i check the memory usage from firefox over a long time and the memory usage starts every time with less then 50 mb and if it reaches 150 mb, i must terminate the browser and restart.
this happens in less then 2 hours oder more then one day, dependently on the pages and the number of pages, which i load.

goodby

Comment 5

13 years ago
Created attachment 217149 [details]
protocol-data from windows perfmon to the hardcopy

datafile for windows perfmon.exe (mmc.exe) with data on which the hardcopy is created

Comment 6

13 years ago
Using Windows XP SP2:

If I leave the browser running, even when I am not using it, the memory usage grows to close to 400MB in size. Eventually Firefox freezes and starts consuming 90+% of the CPU. At this point I have to terminate the application. I've also noticed that while it reports ~400MB of memory in use, that PF use (performance tab under task manager) drops by about twice that amount after terminating the application. I always have My Yahoo and GMail open in a browser. Both of these sites update constantly through javascript (possible cause, no confirmation, just theory). If someone thinks they have a solution and would like me to test, I can be reached at vampire77 {at-thingy} G Mail. In the meantime I must stop using the Beta as performance impact is making the computer completely non-usable.

Comment 7

12 years ago
Unfortunately, monitor log is not helpful without the steps to recreate. This report needs to at least two aspects of good bug reporting documented at http://www.mozilla.org/quality/bug-writing-guidelines.html to move forward, namely Reproducible and Specific (as in a list of steps numbered 1, 2, 3, ...)

Also, a good bug report will address only one aspect of a problem - so morphing this to "right clicking to bring up the context menu increases memory".

user_2_2_2, please document specific steps to reproduce this problem with URLs. Or, close the bug as "invalid" (if determined to not be mozilla, for example an extension) or worksforme (as in, the problem is gone or can't be reproduced). Thanks.

As for other memory issues, there are plenty of bugs with status of new or assigned for almost every conceivable memory issue, from java to gmail. Before searching bugzilla for and commenting in a bug, it is helpful for one to test and eliminate all issues except the problem activity.
Summary: memory usage keeps increasing → right clicking to bring up the context menu increases memory

Comment 8

12 years ago
Opening and closing Bookmarks Toolbar folders does this, too.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a5pre) Gecko/20070527 Minefield/3.0a5pre

Comment 9

12 years ago
(In reply to comment #0 2005-10-08)
> Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5)
> Gecko/20051007 Firefox/1.4.1
> 
> The memory allocation of Firefox, Mozilla and Gecko itself, is never handled
> properly. For example, keep right clicking to bring up the context menu, 

I do not find this in FF 2.0.0.2 or Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a5pre) Gecko/20070527 Minefield/3.0a5pre

so closing this bug WORKSFORME.  All other memory issues reported here are different problems.

(I also was not able to replicate mmortal03's comment 8 using multiple view|toolbars|bookmarks toolbar)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
Version: unspecified → 1.0 Branch

Comment 10

12 years ago
(In reply to comment #9)
> (In reply to comment #0 2005-10-08)
> > Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5)
> > Gecko/20051007 Firefox/1.4.1
> > 
> > The memory allocation of Firefox, Mozilla and Gecko itself, is never handled
> > properly. For example, keep right clicking to bring up the context menu, 
> 
> I do not find this in FF 2.0.0.2 or Mozilla/5.0 (Windows; U; Windows NT 5.1;
> en-US; rv:1.9a5pre) Gecko/20070527 Minefield/3.0a5pre
> 
> so closing this bug WORKSFORME.  All other memory issues reported here are
> different problems.
> 
> (I also was not able to replicate mmortal03's comment 8 using multiple
> view|toolbars|bookmarks toolbar)
> 

I was, safe mode, latest nightly:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a5pre) Gecko/20070528 Minefield/3.0a5pre

Please open this back up.

Comment 11

12 years ago
If you can recreate the problem with a context menu using trunk build please  reopen and list URLS used and the steps and memory amounts you see.

 
> > (I also was not able to replicate mmortal03's comment 8 using multiple
> > view|toolbars|bookmarks toolbar)
> 
> I was, safe mode, latest nightly:
> 
> Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a5pre) Gecko/20070528
> Minefield/3.0a5pre
> 
> Please open this back up.

if you are referring to view|toolbars|bookmarks toolbar ... it would not be appropriate to reopen this bug. while all good problem reports are helpful, please, only one issue per bug[1]. 

If you have a problem that is different from this bug, quantify the memory amounts, with specific steps, (preferably using trunk build) please create a new bug[1].  same is good for comment 3, comment 4 and comment 6.

[1]https://bugzilla.mozilla.org/page.cgi?id=bug-writing.html

Comment 12

12 years ago
I am not just talking about the bookmarks toolbar, I am also talking about context menus.  Also, it doesn't mater what page you are on to reproduce this.  Open up task manager, click on the processes tab, and make the firefox mem usage visible to yourself while using firefox.  Right click, left click, repeat, and watch the mem usage go up.

Comment 13

12 years ago
Also, I don't have the privileges to reopen this, but it needs to be done.
You need to log in before you can comment on or make changes to this bug.