[SeaMonkey] History search is not case insensitive for non-ASCII characters

RESOLVED WORKSFORME

Status

()

Toolkit
Places
--
minor
RESOLVED WORKSFORME
12 years ago
3 months ago

People

(Reporter: neil@parkwaycc.co.uk, Unassigned)

Tracking

({helpwanted})

Trunk
helpwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
Bug 131470 made History search case insensitively for ASCII characters only.
We need to switch to UTF16 strings for truely case insensitive matching.

Comment 1

12 years ago

*** This bug has been marked as a duplicate of 294050 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE

Comment 2

12 years ago
This bug is the SeaMonkey equivalent of bug 294050, not a dup of bug 294050.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Summary: History search is not case insensitive for non-ASCII characters → [SeaMonkey] History search is not case insensitive for non-ASCII characters

Updated

5 months ago
Component: History: Global → Places
Product: Core → Toolkit

Comment 3

3 months ago
I think this was fixed when we moved to use the location bar matching also in queries
Status: REOPENED → RESOLVED
Last Resolved: 12 years ago3 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.