Closed Bug 311676 Opened 17 years ago Closed 17 years ago

selecting an entry in the history dropdown doesn't work (autocomplete broken)

Categories

(Firefox :: Address Bar, defect)

x86
Windows XP
defect
Not set
major

Tracking

()

VERIFIED FIXED

People

(Reporter: mossop, Unassigned)

References

Details

(Keywords: regression)

Attachments

(1 file)

After typing in the location bar and the autocomplete drops down, clicking on an
option with the mouse or pressing enter on one just clears the location bar and
doesnt go to the address.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20051008
Firefox/1.6a1 ID:2005100807
*** Bug 311678 has been marked as a duplicate of this bug. ***
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20051008
Firefox/1.6a1 ID:2005100805

This affects autocomplete on web pages as well. Regressed between 2005-10-07
07:00 and 2005-10-08 07:00. Check-ins: http://tinyurl.com/bww2h
Whiteboard: [trunk only]
Blocks: 311456
*** Bug 311686 has been marked as a duplicate of this bug. ***
Bug 311686 (RESO DUPL) has a testcase for this bug.
*** Bug 311706 has been marked as a duplicate of this bug. ***
Flags: blocking1.9a1+
if u move the cursor around in the address bar after selecting the address with
the keyboard, but before hitting enter, it works. also if u select text, delete
text, anything that moves that cursor around from the end of the address.
*** Bug 311731 has been marked as a duplicate of this bug. ***
It seems like selecting the first option is the only thing that's broken --
selecting any choice after the first (at least in the Firefox URL bar) works fine.
I tried locally backing out the checkins for 240627 and 70698 and it didn't help.
This was also not caused by 311223.
This was not caused by 311024.
Oh, bug 311456 says it caused this; it's just nobody commented here.
I backed out bug 311456.
*** Bug 311802 has been marked as a duplicate of this bug. ***
Fixed by the backout for bug 311456.
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → FIXED
Summary: Cannot select from autocomplete options → selecting an entry in the history dropdown doesn't work (autocomplete broken)
Whiteboard: [trunk only]
*** Bug 311834 has been marked as a duplicate of this bug. ***
*** Bug 311884 has been marked as a duplicate of this bug. ***
*** Bug 311955 has been marked as a duplicate of this bug. ***
*** Bug 311997 has been marked as a duplicate of this bug. ***
When selecting an item from the location bar history using a mouse, the selection populates the location bar but does not navigate to the destination.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.