Saved forms - auto complete selection does no longer work

RESOLVED DUPLICATE of bug 311676

Status

()

Toolkit
Form Manager
--
major
RESOLVED DUPLICATE of bug 311676
12 years ago
10 years ago

People

(Reporter: J.P.Klippel, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20051008 Firefox/1.6a1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20051008 Firefox/1.6a1

Data entered in a form and saved by FF's saved forms feature can no longer be
retrieved correctly. 
The data entered in the form last time is displayed correctly when I enter the
first character. But when I try to select the entry with the mouse or with a
keydown-enter combination the input field snaps blank again. 

Reproducible: Always

Steps to Reproduce:
(Use attached testcase when logged into bugzilla and "Saved forms" feature enabled.)
1. Type the first character of your login into the input field.
2. Select the entry from the proposed autocomplete box.
3. experience bug

The testcase has an input field with the same fieldname as the login field of
bugzilla.

Actual Results:  
The input field snaps blank again.

Expected Results:  
The input field should have been filled with the correct data selected by the user.

Also happens on MacOS nightly:
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20051008
Firefox/1.6a1
(Reporter)

Comment 1

12 years ago
Created attachment 198941 [details]
Testcase

*** This bug has been marked as a duplicate of 311676 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.