Crash on site using Virtools plug-in [@ nsQueryInterface::operator]

RESOLVED WORKSFORME

Status

()

Core
DOM
--
critical
RESOLVED WORKSFORME
12 years ago
4 years ago

People

(Reporter: Olivier Cahagne, Unassigned)

Tracking

({crash})

Trunk
PowerPC
Mac OS X
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [needs retesting on Mac with Virtools plugin], crash signature, URL)

(Reporter)

Description

12 years ago
build ID: Firefox 1.5b2 on MacOSX 10.4.2

Steps to reproduce:
1. download plug-in:
http://player.virtools.com/downloads/playermac3.0.asp
2. Browse to URL:
http://www.nouvelle-clio.renault.fr/game/game.html
3. Wait til it finishes loading the game
4. Right-click and choose fullscreen
5. Escape from fullscreen mode
6. Firefox crashes

Thread 0 Crashed:
0   libxpcom_core.dylib            	0x100018dc nsQueryInterface::operator()(nsID const&, void**) const + 
36
1   libxpcom_core.dylib            	0x10001a2c nsCOMPtr_base::assign_from_qi(nsQueryInterface, nsID 
const&) + 40
2   org.mozilla.firefox            	0x0044e5c8 XPCWrappedNative::GetNewOrUsed(XPCCallContext&, 
nsISupports*, XPCWrappedNativeScope*, XPCNativeInterface*, XPCWrappedNative**) + 68
3   org.mozilla.firefox            	0x004476d4 XPCConvert::NativeInterface2JSObject(XPCCallContext&, 
nsIXPConnectJSObjectHolder**, nsISupports*, nsID const*, JSObject*, int, unsigned*) + 284
4   org.mozilla.firefox            	0x00086968 nsXPConnect::WrapNative(JSContext*, JSObject*, 
nsISupports*, nsID const&, nsIXPConnectJSObjectHolder**) + 148
5   org.mozilla.firefox            	0x00228af0 nsHTMLPluginObjElementSH::GetPluginJSObject(JSContext*, 
JSObject*, nsIPluginInstance*, JSObject**, JSObject**) + 724
6   org.mozilla.firefox            	0x002281c0 nsHTMLExternalObjSH::PostCreate
(nsIXPConnectWrappedNative*, JSContext*, JSObject*) + 152
7   org.mozilla.firefox            	0x005c45c4 nsObjectFrame::NotifyContentObjectWrapper() + 456
8   org.mozilla.firefox            	0x005c2450 nsObjectFrame::Reflow(nsPresContext*, 
nsHTMLReflowMetrics&, nsHTMLReflowState const&, unsigned&) + 2880
9   org.mozilla.firefox            	0x007a0e84 nsLineLayout::ReflowFrame(nsIFrame*, unsigned&, 
nsHTMLReflowMetrics*, int&) + 1064
10  org.mozilla.firefox            	0x005bef58 nsInlineFrame::ReflowInlineFrame(nsPresContext*, 
nsHTMLReflowState const&, nsInlineFrame::InlineReflowState&, nsIFrame*, unsigned&) + 72
11  org.mozilla.firefox            	0x005bebc4 nsInlineFrame::ReflowFrames(nsPresContext*, 
nsHTMLReflowState const&, nsInlineFrame::InlineReflowState&, nsHTMLReflowMetrics&, unsigned&) + 
304
12  org.mozilla.firefox            	0x005be9e0 nsInlineFrame::Reflow(nsPresContext*, 
nsHTMLReflowMetrics&, nsHTMLReflowState const&, unsigned&) + 356
13  org.mozilla.firefox            	0x007a0e84 nsLineLayout::ReflowFrame(nsIFrame*, unsigned&, 
nsHTMLReflowMetrics*, int&) + 1064
14  org.mozilla.firefox            	0x005a733c nsBlockFrame::ReflowInlineFrame(nsBlockReflowState&, 
nsLineLayout&, nsLineList_iterator, nsIFrame*, unsigned char*) + 120
15  org.mozilla.firefox            	0x005a7064 nsBlockFrame::DoReflowInlineFrames(nsBlockReflowState&, 
nsLineLayout&, nsLineList_iterator, int*, unsigned char*, int, int) + 484
16  org.mozilla.firefox            	0x005a6dc0 nsBlockFrame::ReflowInlineFrames(nsBlockReflowState&, 
nsLineList_iterator, int*, int, int) + 148
17  org.mozilla.firefox            	0x005a57dc nsBlockFrame::ReflowLine(nsBlockReflowState&, 
nsLineList_iterator, int*, int) + 972
18  org.mozilla.firefox            	0x005a4d08 nsBlockFrame::ReflowDirtyLines(nsBlockReflowState&, int) + 
776
19  org.mozilla.firefox            	0x005a3444 nsBlockFrame::Reflow(nsPresContext*, 
nsHTMLReflowMetrics&, nsHTMLReflowState const&, unsigned&) + 1016
20  org.mozilla.firefox            	0x007aa2f8 nsBlockReflowContext::ReflowBlock(nsRect const&, int, 
nsCollapsingMargin&, int, int, nsMargin&, nsHTMLReflowState&, unsigned&) + 1180
21  org.mozilla.firefox            	0x005a67cc nsBlockFrame::ReflowBlockFrame(nsBlockReflowState&, 
nsLineList_iterator, int*) + 1232
22  org.mozilla.firefox            	0x005a54b0 nsBlockFrame::ReflowLine(nsBlockReflowState&, 
nsLineList_iterator, int*, int) + 160
23  org.mozilla.firefox            	0x005a4d08 nsBlockFrame::ReflowDirtyLines(nsBlockReflowState&, int) + 
776
24  org.mozilla.firefox            	0x005a3444 nsBlockFrame::Reflow(nsPresContext*, 
nsHTMLReflowMetrics&, nsHTMLReflowState const&, unsigned&) + 1016
25  org.mozilla.firefox            	0x004fa7d8 nsContainerFrame::ReflowChild(nsIFrame*, nsPresContext*, 
nsHTMLReflowMetrics&, nsHTMLReflowState const&, int, int, unsigned, unsigned&) + 148
26  org.mozilla.firefox            	0x005bd334 CanvasFrame::Reflow(nsPresContext*, 
nsHTMLReflowMetrics&, nsHTMLReflowState const&, unsigned&) + 356
27  org.mozilla.firefox            	0x004fa7d8 nsContainerFrame::ReflowChild(nsIFrame*, nsPresContext*, 
nsHTMLReflowMetrics&, nsHTMLReflowState const&, int, int, unsigned, unsigned&) + 148
28  org.mozilla.firefox            	0x005ffcbc nsHTMLScrollFrame::ReflowScrolledFrame(ScrollReflowState 
const&, int, nsHTMLReflowMetrics*, int) + 376
29  org.mozilla.firefox            	0x005ffea4 nsHTMLScrollFrame::ReflowContents(ScrollReflowState*, 
nsHTMLReflowMetrics const&) + 376
30  org.mozilla.firefox            	0x0060053c nsHTMLScrollFrame::Reflow(nsPresContext*, 
nsHTMLReflowMetrics&, nsHTMLReflowState const&, unsigned&) + 736
31  org.mozilla.firefox            	0x004fa7d8 nsContainerFrame::ReflowChild(nsIFrame*, nsPresContext*, 
nsHTMLReflowMetrics&, nsHTMLReflowState const&, int, int, unsigned, unsigned&) + 148
32  org.mozilla.firefox            	0x005f7ca8 ViewportFrame::Reflow(nsPresContext*, 
nsHTMLReflowMetrics&, nsHTMLReflowState const&, unsigned&) + 300
33  org.mozilla.firefox            	0x00148d3c PresShell::ResizeReflow(int, int) + 460
34  org.mozilla.firefox            	0x00206720 nsViewManager::SetWindowDimensions(int, int) + 348
35  org.mozilla.firefox            	0x00209ac0 nsViewManager::DispatchEvent(nsGUIEvent*, 
nsEventStatus*) + 560
36  org.mozilla.firefox            	0x0050a680 ViewWrapper::GetInterface(nsID const&, void**) + 468
37  org.mozilla.firefox            	0x0069af10 nsWindow::DispatchEvent(nsGUIEvent*, nsEventStatus&) + 
172
38  org.mozilla.firefox            	0x0069af9c nsWindow::DispatchWindowEvent(nsGUIEvent&) + 32
39  org.mozilla.firefox            	0x0069b358 nsWindow::ReportSizeEvent() + 152
40  org.mozilla.firefox            	0x00699880 nsWindow::Resize(int, int, int) + 112
41  org.mozilla.firefox            	0x0069991c nsWindow::Resize(int, int, int, int, int) + 80
42  org.mozilla.firefox            	0x00189310 DocumentViewerImpl::SetBounds(nsRect const&) + 92
43  org.mozilla.firefox            	0x00679934 nsDocShell::SetPositionAndSize(int, int, int, int, int) + 64
44  org.mozilla.firefox            	0x006215a4 nsSubDocumentFrame::Reflow(nsPresContext*, 
nsHTMLReflowMetrics&, nsHTMLReflowState const&, unsigned&) + 1056
45  org.mozilla.firefox            	0x001dcec8 nsFrame::BoxReflow(nsBoxLayoutState&, nsPresContext*, 
nsHTMLReflowMetrics&, nsHTMLReflowState const&, unsigned&, int, int, int, int, int) + 948
46  org.mozilla.firefox            	0x001dc950 nsFrame::DoLayout(nsBoxLayoutState&) + 244
47  org.mozilla.firefox            	0x0028a348 nsIFrame::Layout(nsBoxLayoutState&) + 52
48  org.mozilla.firefox            	0x0024cbe4 nsSprocketLayout::Layout(nsIFrame*, nsBoxLayoutState&) + 
2092
49  org.mozilla.firefox            	0x0058a834 nsBoxFrame::DoLayout(nsBoxLayoutState&) + 68
50  org.mozilla.firefox            	0x0028a348 nsIFrame::Layout(nsBoxLayoutState&) + 52
51  org.mozilla.firefox            	0x00205928 nsStackLayout::Layout(nsIFrame*, nsBoxLayoutState&) + 
656
52  org.mozilla.firefox            	0x0058a834 nsBoxFrame::DoLayout(nsBoxLayoutState&) + 68
53  org.mozilla.firefox            	0x00591ae8 nsDeckFrame::DoLayout(nsBoxLayoutState&) + 44
54  org.mozilla.firefox            	0x0028a348 nsIFrame::Layout(nsBoxLayoutState&) + 52
55  org.mozilla.firefox            	0x0024cbe4 nsSprocketLayout::Layout(nsIFrame*, nsBoxLayoutState&) + 
2092
56  org.mozilla.firefox            	0x0058a834 nsBoxFrame::DoLayout(nsBoxLayoutState&) + 68
57  org.mozilla.firefox            	0x0028a348 nsIFrame::Layout(nsBoxLayoutState&) + 52
58  org.mozilla.firefox            	0x0024cbe4 nsSprocketLayout::Layout(nsIFrame*, nsBoxLayoutState&) + 
2092
59  org.mozilla.firefox            	0x0058a834 nsBoxFrame::DoLayout(nsBoxLayoutState&) + 68
60  org.mozilla.firefox            	0x0028a348 nsIFrame::Layout(nsBoxLayoutState&) + 52
61  org.mozilla.firefox            	0x0024cbe4 nsSprocketLayout::Layout(nsIFrame*, nsBoxLayoutState&) + 
2092
62  org.mozilla.firefox            	0x0058a834 nsBoxFrame::DoLayout(nsBoxLayoutState&) + 68
63  org.mozilla.firefox            	0x0028a348 nsIFrame::Layout(nsBoxLayoutState&) + 52
64  org.mozilla.firefox            	0x0024cbe4 nsSprocketLayout::Layout(nsIFrame*, nsBoxLayoutState&) + 
2092
65  org.mozilla.firefox            	0x0058a834 nsBoxFrame::DoLayout(nsBoxLayoutState&) + 68
66  org.mozilla.firefox            	0x0028a348 nsIFrame::Layout(nsBoxLayoutState&) + 52
67  org.mozilla.firefox            	0x0024cbe4 nsSprocketLayout::Layout(nsIFrame*, nsBoxLayoutState&) + 
2092
68  org.mozilla.firefox            	0x0058a834 nsBoxFrame::DoLayout(nsBoxLayoutState&) + 68
69  org.mozilla.firefox            	0x0028a348 nsIFrame::Layout(nsBoxLayoutState&) + 52
70  org.mozilla.firefox            	0x00205928 nsStackLayout::Layout(nsIFrame*, nsBoxLayoutState&) + 
656
71  org.mozilla.firefox            	0x0058a834 nsBoxFrame::DoLayout(nsBoxLayoutState&) + 68
72  org.mozilla.firefox            	0x0028a348 nsIFrame::Layout(nsBoxLayoutState&) + 52
73  org.mozilla.firefox            	0x0058a160 nsBoxFrame::Reflow(nsPresContext*, 
nsHTMLReflowMetrics&, nsHTMLReflowState const&, unsigned&) + 520
74  org.mozilla.firefox            	0x004fa7d8 nsContainerFrame::ReflowChild(nsIFrame*, nsPresContext*, 
nsHTMLReflowMetrics&, nsHTMLReflowState const&, int, int, unsigned, unsigned&) + 148
75  org.mozilla.firefox            	0x005f7ca8 ViewportFrame::Reflow(nsPresContext*, 
nsHTMLReflowMetrics&, nsHTMLReflowState const&, unsigned&) + 300
76  org.mozilla.firefox            	0x00148d3c PresShell::ResizeReflow(int, int) + 460
77  org.mozilla.firefox            	0x00206720 nsViewManager::SetWindowDimensions(int, int) + 348
78  org.mozilla.firefox            	0x00209ac0 nsViewManager::DispatchEvent(nsGUIEvent*, 
nsEventStatus*) + 560
79  org.mozilla.firefox            	0x0050a680 ViewWrapper::GetInterface(nsID const&, void**) + 468
80  org.mozilla.firefox            	0x0069af10 nsWindow::DispatchEvent(nsGUIEvent*, nsEventStatus&) + 
172
81  org.mozilla.firefox            	0x0069af9c nsWindow::DispatchWindowEvent(nsGUIEvent&) + 32
82  org.mozilla.firefox            	0x0069b358 nsWindow::ReportSizeEvent() + 152
83  org.mozilla.firefox            	0x00699880 nsWindow::Resize(int, int, int) + 112
84  org.mozilla.firefox            	0x0069991c nsWindow::Resize(int, int, int, int, int) + 80
85  org.mozilla.firefox            	0x00189310 DocumentViewerImpl::SetBounds(nsRect const&) + 92
86  org.mozilla.firefox            	0x00679934 nsDocShell::SetPositionAndSize(int, int, int, int, int) + 64
87  org.mozilla.firefox            	0x00441a74 nsWebShellWindow::HandleEvent(nsGUIEvent*) + 288
88  org.mozilla.firefox            	0x0069af10 nsWindow::DispatchEvent(nsGUIEvent*, nsEventStatus&) + 
172
89  org.mozilla.firefox            	0x0069af9c nsWindow::DispatchWindowEvent(nsGUIEvent&) + 32
90  org.mozilla.firefox            	0x0069b358 nsWindow::ReportSizeEvent() + 152
91  org.mozilla.firefox            	0x00699880 nsWindow::Resize(int, int, int) + 112
92  org.mozilla.firefox            	0x003048dc nsMacWindow::Resize(int, int, int, int) + 608
93  org.mozilla.firefox            	0x00696a8c nsMacEventHandler::ResizeEvent(OpaqueWindowPtr*) + 
100
94  org.mozilla.firefox            	0x003031ec nsMacWindow::WindowEventHandler
(OpaqueEventHandlerCallRef*, OpaqueEventRef*, void*) + 288
95  com.apple.HIToolbox            	0x931288d4 DispatchEventToHandlers(EventTargetRec*, 
OpaqueEventRef*, HandlerCallRec*) + 692
96  com.apple.HIToolbox            	0x9312802c SendEventToEventTargetInternal(OpaqueEventRef*, 
OpaqueEventTargetRef*, HandlerCallRec*) + 372
97  com.apple.HIToolbox            	0x93127ea8 SendEventToEventTargetWithOptions + 40
98  com.apple.HIToolbox            	0x933d9cc4 SendBoundsChangeEvent(OpaqueWindowPtr*, 
unsigned char, Rect const*, Rect const*, Rect*, Rect const*, Rect const*, unsigned long) + 544
99  com.apple.HIToolbox            	0x933daccc MoveResizeWindowInternal(WindowData*, long, long, 
long, long, unsigned char, unsigned char, unsigned char, unsigned char, Rect const*, unsigned long) + 
1332
100 com.apple.HIToolbox            	0x93175c70 SetWindowBoundsInternal(OpaqueWindowPtr*, 
unsigned short, Rect const*, Rect const*, unsigned long) + 380
101 NPVirtoolsP                    	0x0d49f7c0 VxMoveWindow__FPviiiii + 48
102 NPVirtoolsP                    	0x0d338494 StopFullScreen__16RCKRenderContextFv + 148
103 NPVirtoolsP                    	0x0d4d6768 Step__8NeMoViewFv + 664
104 NPVirtoolsP                    	0x0d4dc5dc NPIdleTimer__8NeMoViewFP23OpaqueEventLoopTimerRefPv 
+ 236
105 com.apple.CoreFoundation       	0x9075ed10 __CFRunLoopDoTimer + 184
106 com.apple.CoreFoundation       	0x9074b688 __CFRunLoopRun + 1680
107 com.apple.CoreFoundation       	0x9074ac3c CFRunLoopRunSpecific + 268
108 com.apple.HIToolbox            	0x93129ac0 RunCurrentEventLoopInMode + 264
109 com.apple.HIToolbox            	0x9320e64c GetNextEventMatchingMask + 116
110 com.apple.HIToolbox            	0x9320e51c WNEInternal + 140
111 com.apple.HIToolbox            	0x9320e47c WaitNextEvent + 76
112 org.mozilla.firefox            	0x00690afc nsMacMessagePump::GetEvent(EventRecord&) + 116
113 org.mozilla.firefox            	0x00690a58 nsMacMessagePump::DoMessagePump() + 48
114 org.mozilla.firefox            	0x002fe89c nsAppShell::Run() + 56
115 org.mozilla.firefox            	0x0039e074 nsAppStartup::Run() + 60
116 org.mozilla.firefox            	0x000142d8 XRE_main + 3696
117 org.mozilla.firefox            	0x0000f6a8 start + 432
118 org.mozilla.firefox            	0x0000f528 start + 48

Updated

12 years ago
Severity: normal → critical
Using FF1.5b2, I can't reproduce this because the plugin causes FF to hang just
after loading completely.

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b5) Gecko/20051006
Firefox/1.4.1
Assignee: nobody → general
Component: General → DOM
Product: Firefox → Core
QA Contact: general → ian
Version: 1.5 Branch → 1.8 Branch

Comment 2

12 years ago
Firefox also frequently crashes when opening a new tab or new window when a webpage using the virtools plugin is displayed. Tested with Firefox 1.5 and the 20050106 nightly build of 1.6a
Is this a problem on trunk?  Or just 1.8 branch?
(Reporter)

Comment 4

12 years ago
Cannot reproduce on trunk because Virtools complains about not being able to load any .vmo file.

FF 1.5.0.2 only crashed once and it seems to be a plug-in issue: TB17786854M.

Virtools version 3.5.0.30 from:
http://player.virtools.com/downloads/playermac3.5.asp
(Reporter)

Comment 5

10 years ago
Still crashing using FF 3.0b2 + MacOSX 10.5.1 PPC and Virtools 4.0.0.97.
Loading URL:
http://www.actiplay.com/demos/3D/total3D.htm
Crash report:
http://crash-stats.mozilla.com/report/index/f99093ee-bd73-11dc-917e-001a4bd43ed6?date=2008-01-07-22

Comment 6

10 years ago
I can't get it to install on XP with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3pre) Gecko/2008010705 Minefield/3.0b3pre from http://www.virtools.com/downloads/player/install.asp#install

.xpi comes up with "unsupported package -244"

on vista I can't even get the package from http://www.virtools.com/downloads/player/install.asp#install - it says vista is unsupported with this browser (IE works)

changed version to unspecified, since both trunk and 1.8 fail for oliver
Version: 1.8 Branch → unspecified

Comment 7

10 years ago
let's use Trunk if it applies, if not, favor the most recently supported branch, if there isn't one, pick unspecified.
Version: unspecified → Trunk

Comment 8

9 years ago
It crashes on Windows Vista, Firefox 3.0.1, too. Also, if you are playing a game using OpenGL, the CPU Meter gets stuck to 100%.

Comment 9

8 years ago
The crash report in comment 3 got lost.  Olivier, can you provide a new stack trace, preferably from Firefox 3.5?  (Or mark the bug report as worksforme if you can no longer reproduce.)
Whiteboard: [needs retesting on Mac with Virtools plugin]
(Reporter)

Comment 10

8 years ago
Jesse, I no longer use a Mac, I cannot test again.
They still support PowerPC though, can anyone test it ?
http://dl.3dvia.com/software/3dvia-player/install/
Assignee: general → nobody
QA Contact: ian → general
(Assignee)

Updated

6 years ago
Crash Signature: [@nsQueryInterface::operator]

Comment 11

5 years ago
Thomas, could you test this?
Keywords: qawanted

Updated

4 years ago
Crash Signature: [@nsQueryInterface::operator] → [@ nsQueryInterface::operator]
Summary: Crash on site using Virtools plug-in [@nsQueryInterface::operator] → Crash on site using Virtools plug-in [@ nsQueryInterface::operator]

Comment 12

4 years ago
I don't have a powerPC to test this and the game site is no longer valid, but I did check Socorro and there are no crashes with this signature there.

Please only reopen this bug if you can reproduce it and give more details about it.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Keywords: qawanted
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.