If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

it gives download error when you try to install extension from http://fasterfox.mozdev.org/

RESOLVED WORKSFORME

Status

()

Toolkit
Add-ons Manager
RESOLVED WORKSFORME
12 years ago
9 years ago

People

(Reporter: gabe, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20051008 Firefox/1.6a1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20051008 Firefox/1.6a1

it gives download eroor when you try too instill extensions not from
https://addons.mozilla.org

Reproducible: Always

Steps to Reproduce:
1.go too a site with firefox extensions 
2.try and instill anone 
3.gives download eroor

Actual Results:  
eroor

Expected Results:  
should let you instill them
WFM

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20051008
Firefox/1.6a1 ID:2005100805

Can you give an example of where this occurs?
(Reporter)

Comment 2

12 years ago
http://fasterfox.mozdev.org/


is where it occurs after i add site too list click instill and wont let me
instill i save it too dektop and then use firefox too run it it will let me
instill it
(Reporter)

Comment 3

12 years ago
deer park could not instill the file at 

http//mozdev.sweettooth.org/fasterfox/fasterfox-0.7.4-fx.xpi

becase.download error
I could reproduce this, once. Subsequent attempts worked fine (even after
clearing the cache). The extension in question is on mozdev which redirects to a
mirror for downloading the file, my bet is that one of the mirrors doesnt have
the file or is not set up correctly.

Updated

12 years ago
Summary: it gives download eroor when you try too instill extensions not from https://addons.mozilla.org → it gives download error when you try to install extension from http://fasterfox.mozdev.org/
WFM - highly suspect this is a problem with the file on one of the mirrors or
the config of one of the mirrors and not the Extension Manager
The url given in comment 3 goes to what seems to be an unconfigured website.
I've emailed the mirrors list at mozdev to get their input on this.
ewww... that's a bad thing. I've never received a response that didn't take a
week from the admin email at mozdev though I don't know a better way to inform
them of their mis-config - maybe bugzilla.mozdev.org
(Reporter)

Comment 8

12 years ago
defnetly bad is this bug confiremed unconfiremed or what
Well, it isn't an Extension Manager or Firefox bug so it is actually invalid
since bugzilla.mozilla.org isn't for mozdev.org bugs and this needs to be fixed
by mozdev. Once they fix it this will most likely get resolved WFM.
(Reporter)

Comment 10

12 years ago
still does not answer why i can save this too my pc and open with firefox 100
percent of the time that should not work
There are several mirrors. If you are sent to the mirror that is invalid you get
there placeholder / error page. If you right click / save as and are sent to
that mirror you will save the placeholder / error page as fasterfox-0.7.4-fx.xpi
in the case of faster fox. This is not a valid extension obviously so it will
not install.
Filed http://bugzilla.mozdev.org/show_bug.cgi?id=11779 as well to notify the
mozdev guys.
I suspect the xpi was removed and the link hadn't been updated yet or some other
timing issue with mozdev. This is now WFM and the link to sweetooth that I am
redirected to is:

http://mozdev.sweetooth.org/fasterfox/fasterfox-0.7.5-fx.xpi
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
*** Bug 311876 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

9 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.