"firefox is already running" when using profile from 1.0.7

VERIFIED DUPLICATE of bug 278860

Status

()

defect
--
major
VERIFIED DUPLICATE of bug 278860
14 years ago
11 years ago

People

(Reporter: reub2000, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b5) Gecko/20051008 Firefox/1.4.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b5) Gecko/20051008 Firefox/1.4.1

Firefox will not start up when using my old firefox 1.0.x profile in deer park.
I get the error saying that firefox is already running. Creating a new profile,
and firefox started up just fine.

Reproducible: Always




OS: Gentoo Linux
Kernel: linux, 2.6.13-archck6.1
delete parent.lock for your profile
I can't find a parent.lock file in my profile. 
(In reply to comment #1)
> delete parent.lock for your profile

That should be only be a temp solution.
Issue may be fixed, Firefox prompt to 
1. switch previous instance
2. Kill previous instance or
3. just exist current instance

This happens in windows too..
Exact error dialog text:

Firefox is already running, but is not responding. To open a new window, you must first close the existing Firefox process, or restart your system.

My profile is on an encrypted drive. This drive is not yet available immediately after the system starts (a password must be entered first). When Firefox launches first, it gives this error message instead of saying that it is unable to find the profile. FF 1.0.7 used to bring up the profile selection dialog which is much more appropriate.

*** This bug has been marked as a duplicate of 278860 ***
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.