Closed Bug 311795 Opened 15 years ago Closed 12 years ago

Form autocomplete dropdown menu cannot be invoked by a keyboard arrow button probably due to events such as onkeyup and onblur

Categories

(Toolkit :: Form Manager, defect)

defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: tyl2, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1

No matter how many numbers you had previously entered in the From: field on the
AT&T Wireless SMS page, the autocomplete dropdown will make only a micro-second
appearance when you try to use the up or down arrow buttons on your keyboard to
make a selection. This doesn't happen in the To: field, and I suspect it has to
do with functions assigned to certain events in the From: field.

The To: field => <input type="text" name="recipient" maxlength="50" size="25"
value="" style="width:220px" class="blackCopy">

The From: field => <input type="text" name="sender" maxlength="50" size="25"
value="" onkeyup="calculate();this.blur();this.focus();" onblur="calculate();"
style="width:220px" class="blackCopy">

Reproducible: Always

Steps to Reproduce:
1. Enter any 10-digit number in the To: field.
2. Enter any 10-digit number in the From: field.
3. Enter anything in the Subject or Message textboxes.
4. Hit the Send Message button.
5. Repeat steps 1-4 as you desire.
6. Enter 0 or however many digits you want in the From: field that would should
lead to previously-entered numbers being shown when you press the up or down
button on your keyboard.
7. Press the up or down button on your keyboard.
Actual Results:  
Good luck if you can catch any of the choices now being offered by the dropdown
menu.

Expected Results:  
A dropdown is shown and you may make a choice through keyboard selection.

This is a regression from Firefox 1.5b1, which had fixed the problem that
existed in Fx 1.0.x releases. I hope it'll be fixed before v1.5 is released.
This bug seems to be related to Bug #297329.
Flags: blocking1.8.1?
Flags: blocking1.8rc1?
Flags: blocking1.8rc1? → blocking1.8rc1-
Related problem?

http://www.nationalrail.co.uk/index.html

This major site has a recent problem with Firefox

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b5) Gecko/20051006
Firefox/1.4.1

Steps to reproduce

1 Load site
2 Follow site link to online timetable
3 Follow site link to journey planner
4 Enter origin and destination details, set dates
5 Attempt to set times and you'll find that <select> list doesn't appear on a
mouse click though its contents are still accessible via the 'Page up/page down'
keys.


Mark
Product: Firefox → Toolkit
WFM in Firefox 3.1 trunk.
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.