Form select element colors are wrong

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
13 years ago
6 years ago

People

(Reporter: golowenow, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

Since the new update the drop-down menu on my webpage has changed colors in
Firefox. The background color is supposed to be BLACK and the FONTS are supposed
to be a light shade of purple as the rest of the webpage font colors are. As it
is now...FF is showing a yellow background and the fonts are light blue. The
code for the menu is unchanged for a long time now so I know it is not the
webpage having/causing the issue.

Reproducible: Always

Steps to Reproduce:
1. Just visit my website at the URL listed
2.
3.

Actual Results:  
Does not change

Expected Results:  
Please read above.
(Reporter)

Updated

13 years ago
Alias: Menubug
(Reporter)

Comment 1

13 years ago
Made an error. Only the background is wrong. The FONTS are correct. Checked it
in IE and background is BLACK. In FF it is yellow. Sorry for the error in the
report.
I see no difference in the display between Mozilla/5.0 (Windows; U; Windows NT
5.1; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1 and IE 6. I also don't see an
applet with a dropdown menu. Could you provide a testcase with only the applet
that's exibiting this issue?

Please do not set your own alias.
Alias: Menubug
(Reporter)

Comment 3

13 years ago
Have created a testing webpage at http:golowesstamps.com/jm1.htm
Again the same thing is happening to the menu.
Yellow background inside of it when it should be black.
Very odd. Only started when I installed the new update to FF.
(Reporter)

Comment 4

13 years ago
LOL! http://www.golowesstamps.com/jm1.htm
New to this place hehe
That's a standard HTML form element with a JavaScript function to handle the
submit action and change the statusbar text. The script itself has nothing to do
with the way the element is colored.

1.4.1 and 1.0.7 are displaying the colors as specified by the page and I again
see no difference between them and IE6. I suspect that the upgrade to 1.0.7
caused an extension of yours to misbehave. Try using safe mode to disable all
extensions and see if that resolves this issue
(http://kb.mozillazine.org/safe_mode).
Summary: Java drop-down menu colors are wrong → Form select element colors are wrong
(Reporter)

Comment 6

13 years ago
AHHA! Yes it was the Google Toolbar extention causing the problem. Running in 
safe-mode showed that FF was doing fine and displaying the menu properly. When 
I updated FF there was ALSO an update to the google toolbar extention. I have 
since uninstalled the toobar then downloaded the basic googlebar and installed 
it. Then got the Google pagerank status extention as well and the menu NOW 
shows the correct colors. Apparently the Google toolbar with pagerank feature 
is not compatible with the new FF update. I tried to install it and it was 
rejected. Hope this helps other FF people out there having similar problems. 
Thank you Ryan for all your help on this. Once again am a happy FF user!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Updated

13 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Updated

13 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.