Italic text in MS Sans Serif font not separated by blank from regular text

RESOLVED INVALID

Status

Core Graveyard
GFX: Win32
RESOLVED INVALID
12 years ago
9 years ago

People

(Reporter: cjackson, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

The following HTML example will show the problem when using Firefox (or Netscape):

<font face="MS Sans Serif">After <i>italics</i> space <b>missing</b> using MS
Sans Serif font</font>
<p>
<font face="Arial">After <i>italics</i> space okay with Arial</font>
<p>
After <i>italics</i> space okay with default font</font>

With MS Sans Serif the space after the </i> tag is missing.



Reproducible: Always

Steps to Reproduce:
Just create an html file with the code above.

Actual Results:  
No space in the MS Sans Serif line between the words "italics" and "space".

Expected Results:  
Inserted a space in the MS Sans Serif line between the words "italics" and "space".
Created attachment 199045 [details]
IE/Firefox comparison screenshot

Screenshot comparing IE's rendering with ours, looks exactly the same to me. Am
I missing how it's a Firefox bug that MS Sans Serif is a terrible font to mix
italic and normal characters?
This might be a similar issue to bug 52596, although that was only on Win9x. See
especially bug 52596 comment 23
Assignee: nobody → win32
Component: General → GFX: Win32
Product: Firefox → Core
QA Contact: general → ian
Version: unspecified → Trunk
(Reporter)

Comment 3

12 years ago
I've tried the test page with a new profile in Firefox and the results are
correct. I guess the bug is in one of the extensions I use.

Will do some more research.
(Reporter)

Comment 4

12 years ago
My apologies!

Please disregard my last comment. Even with a new profile the problem persists.

(Reporter)

Comment 5

12 years ago
The following example with CSS displays differently in Firefox than in IE:

<html>
	<head>
		<title>Left I on the News</title>
		<style type="text/css">
		
body{margin:0px;padding:0px;background:#ffffff;color:#111111;font-family:Lucida
Grande,MS Sans 

Serif,Lucida Sans Unicode,Verdana,Geneva,Lucida,Arial,Helvetica,Sans-Serif;}
		</style>
<body>
<P>Consider this story</A> from the <I>Los Angeles Times</I> on the fighting in
Western Iraq.
</body>
</html>

Removing "MS Sans Serif" from the font list results in identical screenshots!
That last example is not really relevant. MSIE (and Opera) ignore MS Sans Serif
in the font list because of the line breaks in the middle. If you remove those
the example is much the same in all three browsers.
Please attach a valid testcase that demonstrates the problem. Note that when
specifying a font family that includes spaces in a style, you must surround the
full name with double quotes.
(Reporter)

Comment 8

12 years ago
To summarise:

1. There is presumably a bug in the Windows MS Sans Serif font itself which
results in all browsers not displaying a space when changing from italic to
regular text. Since MSIE and Mozilla give identical results I think it's best to
leave it as it is. 

2. Mozilla will handle a linefeed in the middle of a font name in a list of
fonts, and MSIE will not. Since the CSS spec states "Font names containing
whitespace should be quoted" and the CSS statement in the example is in error
it's best to leave this as well. 
(Reporter)

Updated

12 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → INVALID
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.