Error while printing in Firefox 1.5 Beta 1 and 2 on Mac OS X Tiger

RESOLVED WORKSFORME

Status

()

--
major
RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: jijoejv, Unassigned)

Tracking

1.5.0.x Branch
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1

I have a Samsung CLP-550N hooked up to my home network. My Powerbook runs Mac OS
X Tiger and happily prints from all applications to this printer, except from
Firefox 1.5 beta 1 and 2. 

So what do I mean by "all applications"? I've tried printing from other Mac
applications like TextEdit, NeoOffice, Safari, Preview, Adobe Acrobat Reader....
- they all print fine on my printer. Even Firefox 1.0.x prints fine. 

However, when I try to print from Firefox 1.5 Beta 1 or 2, the Mac OS side of
the printer (the printer client) gives an error saying - "Print File was not
accepted (client-error-bad-request)!". The document won't print and I've to
eventually kill the print job.

Since I can print from other Mac OS apps and Firefox 1.0.x, I am thinking this
may have something to do with communication between FF 1.5 b1 and b2 and Mac OS
X print subsystem. I even tried creating a clean profile for FF 1.5 b1/b2 -
still the same error.

I will try to attach a screen shot of the error message - as soon as I figure
out how to do so in Bugzilla.

Reproducible: Always

Steps to Reproduce:
1.On Mac OS X Tiger with Samsung CLP-550N printer driver, navigate to any web page
2.Use <Command>+P (or File > Print from the menu) to launch print dialog
3.Click Ok in print dialog
Actual Results:  
Got the error message saying "Print File was not accepted
(client-error-bad-request)!"

Expected Results:  
Print the web page
(Reporter)

Comment 1

13 years ago
Created attachment 199042 [details]
Screen shot of error message
(Reporter)

Updated

13 years ago
Version: unspecified → 1.5 Branch
(Reporter)

Comment 2

13 years ago
Created attachment 201597 [details]
CUPS error_log file with LogLevel set to debug2
(Reporter)

Comment 3

13 years ago
Same issue with Firefox 1.5 RC1. See line # 9065 in attached file (bad-print.txt.gz) for the error.
(Reporter)

Comment 4

13 years ago
This works for me now. I had to remove the declared printer config on my Mac and re-add it. After that, all is well.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.