If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

crash before any (visible) element in the page loads

VERIFIED INCOMPLETE

Status

()

Firefox
General
--
critical
VERIFIED INCOMPLETE
12 years ago
7 years ago

People

(Reporter: Gezim Hoxha, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

10.64 KB, application/x-shellscript
Details
(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

When trying to visit above URL, Firefox crashes before page loads.

Reproducible: Always

Steps to Reproduce:
1.Open Firefox
2.Either click on a link that points to
http://www.adobe.com/products/indesign/main.html or just type the url in the
address bar clikc "Go"
3.Prepare to get crashed

Actual Results:  
Firefox crashed.

Expected Results:  
Ummm..not crash and display the page.

I tried to run it from the shell but I got no error in shell.
The extensions I'm using are(if this helps):
Flashblock 1.9
Context Search 0.2
Add Bookmark Here 0.5.3
SessionSaver .2
FLST 0.8.3
Web Developer 0.9.4
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051009
Firefox/1.4.1 ID:2005100902

WFM, also in 1.0.7. Does it also crash in the safe mode?
http://kb.mozillazine.org/Safe_Mode_(Firefox)
(Reporter)

Comment 2

12 years ago
(In reply to comment #1)
> Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051009
> Firefox/1.4.1 ID:2005100902
> 
> WFM, also in 1.0.7. Does it also crash in the safe mode?
> http://kb.mozillazine.org/Safe_Mode_(Firefox)
> 

Yes, it also crashes in safe mode, however, it gives a big hint to the problem:

[gezim@laptopi ~]$ firefox -safe-mode

(firefox-bin:27175): Gdk-WARNING **: gdk_property_get(): length value has
wrapped in calculation (did you pass G_MAXLONG?)
*** loading the extensions datasource
UA: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922
Fedora/1.0.7-1.1.fc4 Firefox/1.0.7:, extra:  Firefox/1.0.7
/usr/lib/firefox-1.0.7/run-mozilla.sh: line 159: 27175 Segmentation fault     
"$prog" ${1+"$@"}
[gezim@laptopi ~]$

(BTW, you missed a space on the link above, so as it is, it doesn't work)
(Reporter)

Comment 3

12 years ago
Created attachment 199048 [details]
offending file

Comment 4

12 years ago
WFM in today's trunk and in 1.0.7 on Linux. It looks like Flash is causing the crash. Does upgrading to the latest version of Flash solve the crash? http://plugindoc.mozdev.org/linux.html#Flash
(Reporter)

Comment 5

12 years ago
(In reply to comment #4)
> Does upgrading to the latest version of Flash solve the crash?
> http://plugindoc.mozdev.org/linux.html#Flash

Nope, still the same problem after installing flash in /usr/lib/firefox-1.0.7/ .
I don't think it's a flash problem because I can see other pages that contain flash just fine.

-Gezim

reporter, Do you still see this problem. If you do not, please close the bug with resolution WORKSFORME, INVALID, etc as may be appropriate to your situation (but not FIXED unless you know the bug with the patch). 

If you still see problem using a current version of Firefox or trunk build, please provide additional detail.
Whiteboard: closeme 2008-12-10
@Reporter, we have not heard back from you in a while, so I am closing this bug as INCOMPLETE. You can reopen this bug if more information becomes available. Some helpful information you can provide us is found at http://new.quality.mozilla.org/bug-writing-guidelines.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INCOMPLETE
Whiteboard: closeme 2008-12-10

Updated

7 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.