Closed Bug 311866 Opened 14 years ago Closed 9 years ago

"About popup blocking" dialog appears when it shouldn't

Categories

(Firefox :: General, defect)

defect
Not set

Tracking

()

RESOLVED INVALID

People

(Reporter: Gavin, Unassigned)

References

()

Details

(Keywords: regression, uiwanted)

Bug 250716's patch was completely wrong wrt to the "About Popup Blocking" dialog
it intended to replace with a browser notification bar. It made this dialog
appear when clicking on the "Don't show this message when popups are blocked"
option from the "Options" menu of the notification bar or the status bar icon
menu. It doesn't make sense to display a dialog to explain popup blocking to
someone who just selected the option to not display the notification for it.
This also made the privacy.popups.firstTime pref useless, since it is never
written to and this always true. The dialog is therefore always displayed when
selecting the "Don't show this message when popups are blocked" option.

This bug shipped with 1.0.
Status: NEW → ASSIGNED
Priority: -- → P4
Target Milestone: --- → Firefox1.6-
I'd guess the intended sense was to show a popup getting across something like:

You've shut off the blocked popup infobar, so now your only indication of
blocked popups will be an obscure icon on the statusbar, which you can click to
see what was blocked, open wanted popups, or turn the infobar back on.
Ok, I understand the intent now, but there are still issues with the "firstTime"
pref not being set, which makes the dialog appear each time you disable the
message bar instead of only the first. That doesn't sound like intended behavior.

Also, I'd argue the current dialog text needs tweaking. It was initially used
the first time a popup was blocked, so the explanation of popup blocking in line
#1 made sense then, but not now. Seems to me like taking out the first part or
changing it to something along the lines of the text in Phil's comment 1 would
make much more sense.
Priority: P4 → P2
Whiteboard: [needs ui review]
Keywords: uiwanted
Whiteboard: [needs ui review]
Target Milestone: Firefox 2 → Firefox 2 beta1
Priority: P2 → --
Target Milestone: Firefox 2 beta1 → ---
Priority: -- → P2
Target Milestone: --- → Firefox 3 M8
Target Milestone: Firefox 3 M8 → ---
Assignee: gavin.sharp → nobody
Status: ASSIGNED → NEW
Priority: P2 → --
The patch for bug 604419 removed the dialog altogether, rendering this INVALID.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.