selected language ignored during inline spell check

RESOLVED WORKSFORME

Status

Thunderbird
Message Compose Window
--
major
RESOLVED WORKSFORME
13 years ago
11 years ago

People

(Reporter: Sander Goudswaard, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051008 Firefox/1.4.1
Build Identifier: version 1.5 Beta 2 (20051008)

When opening a new message window, it appears that the English/US dictionary is
still being used for spell checking the message, even though a different pack is
selected.

Reproducible: Always

Steps to Reproduce:
1. Download the Dutch language pack and install it
2. Selected Dutch language through Tools, Options, Composition, Spelling.
3. Open Compose window.
4. Type some Dutch text (or grab some from www.nu.nl) .

Actual Results:  
The message is checked with English/US language.

Expected Results:  
Use the Dutch dictionary to check the spelling of the message.
(Reporter)

Comment 1

13 years ago
The language inside the Compose window can be checked with Options -> Check
spelling.

Comment 2

13 years ago
(In reply to comment #1)
> The language inside the Compose window can be checked with Options -> Check
> spelling.

I think he is talking about the "Spell as you type" feature. I didn't find a
possibility to change the language of the "on-the-fly" spell checker. It's
always checked in English.

Quite annoying, since i'm writing a lot of mail in different languages.

What about a submenu in the options menu called "Spelling language"?
Or a keyboard shortcut (maybe with a small popup to quickly select the dict)?

Comment 3

12 years ago
(In reply to comment #2)
> (In reply to comment #1)
> > The language inside the Compose window can be checked with Options -> Check
> > spelling.
> 
> I think he is talking about the "Spell as you type" feature. I didn't find a
> possibility to change the language of the "on-the-fly" spell checker. It's
> always checked in English.

It's possible in Thunderbird 1.5 RC1 (20051025). Use the Spell-button of the mail-toolbar in a compose-window : it has a small popup on the right hand side.

Reporter: this works for me in the latest version. I'm regularly switching between English, Dutch, Spanish and German, without problems. We could add the language in the menubar though (I though there was a bug for that).

Comment 4

11 years ago
WFM with Thunderbird 1.5.0.9 (20061207).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.