Attached calendar crashes sunbird-nightly, and gets truncated during save

RESOLVED DUPLICATE of bug 305857

Status

--
critical
RESOLVED DUPLICATE of bug 305857
13 years ago
13 years ago

People

(Reporter: alf, Assigned: mostafah)

Tracking

Details

Attachments

(2 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050909 Fedora/1.0.6-1.2.fc4 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20050913 Mozilla Sunbird/0.2+

Editing a WebDav calendar may crash sunbird, with data loss.

Reproducible: Always

Steps to Reproduce:
1.Load the attached calendar from a webdav server.  
2. Change the October 8,9 entries to  "All day".
3. Sunbird will crash and the remote calendar file gets truncated.
(Reporter)

Comment 1

13 years ago
Created attachment 199066 [details]
this makes "IT" happen
(Reporter)

Updated

13 years ago
Summary: Attached calendar crashes sunbird, and gets truncated during save → Attached calendar crashes sunbird-nightly, and gets truncated during save

Comment 2

13 years ago
Created attachment 199070 [details]
stack

stack from crash.  Happens just after the terminal outputs 'adding a
VTIMEZONE'.

Comment 3

13 years ago
Confirming for now.  I thought gekacheka had a bug about something similar, but
I can't seem to find it right now.  CC'ing dmose since he's working on another,
perhaps related crasher with our ics processing.
Status: UNCONFIRMED → NEW
Ever confirmed: true

*** This bug has been marked as a duplicate of 305857 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.