If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

crash if I click on bookmarks in tool bar [@ TestNode::Propagate]

RESOLVED DUPLICATE of bug 263407

Status

()

Core
XUL
--
critical
RESOLVED DUPLICATE of bug 263407
12 years ago
9 years ago

People

(Reporter: Vicki Cohen, Unassigned)

Tracking

1.7 Branch
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

Am new to Firefox (1 month).  Every time I click on Bookmarks in the tool bar
Firefox crashes.  It happens each time, does not seem to matter what website I'm
in.  Talkback comes up each time.  Some talkback incident IDs are: TB9811272Q,
TB95967994, TB959655M, TB10482033X, TB10479634X, TB10433770M.  I'm on an iMac
(5yrs old) with MacOs 10.2.1.

Reproducible: Always

Steps to Reproduce:
1.move curser to Bookmarks on Toolbar
2.Click mouse
3.crash

Actual Results:  
Firefox crashes, talkback comes up to report incident

Expected Results:  
bookmarked the site! and let me continue.

Comment 1

12 years ago
Incident ID: 9811272
Stack Signature	libSystem.B.dylib.63.0.0 + 0x1b40c (0x9001b40c) bcdf3e6d
Product ID	Firefox10
Build ID	2005091516
Trigger Time	2005-09-27 20:59:06.0
Platform	MacOSX
Operating System	Darwin 6.8
Module	libSystem.B.dylib.63.0.0 + (0001b40c)
URL visited	
User Comments	trying to open bookmarks
Since Last Crash	94824 sec
Total Uptime	135205 sec
Trigger Reason	SIGABRT: Abort: (signal 6)
Source File, Line No.	N/A
Stack Trace 	
libSystem.B.dylib.63.0.0 + 0x1b40c (0x9001b40c)
libSystem.B.dylib.63.0.0 + 0x5ce0c (0x9005ce0c)
__cxxabiv1::__unexpected()
operator()
TestNode::Propagate() 
[/builds/tinderbox/Fx-Aviary1.0.1/Darwin_7.9.0_Depend/mozilla/content/xul/templates/src/nsRuleNetwork.cpp,
line 887]
TestNode::Propagate() 
[/builds/tinderbox/Fx-Aviary1.0.1/Darwin_7.9.0_Depend/mozilla/content/xul/templates/src/nsRuleNetwork.cpp,
line 887]
RootNode::Propagate() 
[/builds/tinderbox/Fx-Aviary1.0.1/Darwin_7.9.0_Depend/mozilla/content/xul/templates/src/nsRuleNetwork.cpp,
line 887]
nsXULContentBuilder::CreateContainerContents() 
[/builds/tinderbox/Fx-Aviary1.0.1/Darwin_7.9.0_Depend/mozilla/content/xul/templates/src/nsXULContentBuilder.cpp,
line 100]
nsXULContentBuilder::OpenContainer() 
[/builds/tinderbox/Fx-Aviary1.0.1/Darwin_7.9.0_Depend/mozilla/content/xul/templates/src/nsXULContentBuilder.cpp,
line 704]
nsXULContentBuilder::AttributeChanged() 
[/builds/tinderbox/Fx-Aviary1.0.1/Darwin_7.9.0_Depend/mozilla/content/xul/templates/src/nsXULContentBuilder.cpp,
line 1633]
nsXULDocument::AttributeChanged() 
[/builds/tinderbox/Fx-Aviary1.0.1/Darwin_7.9.0_Depend/mozilla/content/xul/document/src/nsXULDocument.cpp,
line 1137]
nsXULElement::SetAttrAndNotify() 
[/builds/tinderbox/Fx-Aviary1.0.1/Darwin_7.9.0_Depend/mozilla/content/xul/content/src/nsXULElement.cpp,
line 2193]
nsXULElement::SetAttr() 
[/builds/tinderbox/Fx-Aviary1.0.1/Darwin_7.9.0_Depend/mozilla/content/xul/content/src/nsXULElement.cpp,
line 2153]
nsMenuX::MenuSelected() 
[/builds/tinderbox/Fx-Aviary1.0.1/Darwin_7.9.0_Depend/mozilla/widget/src/mac/nsMenuX.cpp,
line 65]
MyMenuEventHandler() 
[/builds/tinderbox/Fx-Aviary1.0.1/Darwin_7.9.0_Depend/mozilla/widget/src/mac/nsMenuX.cpp,
line 123]
HIToolbox.124.0.0 + 0x2c54 (0x969a2c54)
HIToolbox.124.0.0 + 0x2fbc (0x969a2fbc)
HIToolbox.124.0.0 + 0x63d0 (0x969a63d0)
HIToolbox.124.0.0 + 0x68a0c (0x96a08a0c)
HIToolbox.124.0.0 + 0x89300 (0x96a29300)
HIToolbox.124.0.0 + 0xce790 (0x96a6e790)
HIToolbox.124.0.0 + 0x44fec (0x969e4fec)
HIToolbox.124.0.0 + 0x99318 (0x96a39318)
HIToolbox.124.0.0 + 0xbcbf8 (0x96a5cbf8)
nsMacMessagePump::DoMouseDown() 
[/builds/tinderbox/Fx-Aviary1.0.1/Darwin_7.9.0_Depend/mozilla/widget/src/mac/nsMacMessagePump.cpp,
line 77]
nsMacMessagePump::DispatchEvent() 
[/builds/tinderbox/Fx-Aviary1.0.1/Darwin_7.9.0_Depend/mozilla/widget/src/mac/nsMacMessagePump.cpp,
line 443]
nsMacMessagePump::DoMessagePump() 
[/builds/tinderbox/Fx-Aviary1.0.1/Darwin_7.9.0_Depend/mozilla/widget/src/mac/nsMacMessagePump.cpp,
line 312]
nsAppShell::Run() 
[/builds/tinderbox/Fx-Aviary1.0.1/Darwin_7.9.0_Depend/mozilla/widget/src/mac/nsAppShell.cpp,
line 114]
xre_main() 
[/builds/tinderbox/Fx-Aviary1.0.1/Darwin_7.9.0_Depend/mozilla/toolkit/xre/nsAppRunner.cpp,
line 710]
_start()   start()
Component: Bookmarks → XP Toolkit/Widgets: XUL
Product: Firefox → Core
QA Contact: bookmarks → xptoolkit.xul
Summary: crash if I click on bookmarks in tool bar → crash if I click on bookmarks in tool bar [@ TestNode::Propagate]
Version: unspecified → 1.7 Branch

Comment 2

12 years ago

*** This bug has been marked as a duplicate of 263407 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE

Updated

9 years ago
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: xptoolkit.xul → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.