[@ libobjc.A.dylib.227.0.0 + 0x11f4]

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
13 years ago
7 years ago

People

(Reporter: timeless, Assigned: jaas)

Tracking

({crash})

1.7 Branch
PowerPC
Mac OS X
crash

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

13 years ago
Incident ID: 10322098
Stack Signature	libobjc.A.dylib.227.0.0 + 0x11f4 (0x913041f4) 159c91ca
Product ID	Firefox10
Build ID	2005071604
Trigger Time	2005-10-06 18:37:08.0
Platform	MacOSX
Operating System	Darwin 7.9.0
Module	libobjc.A.dylib.227.0.0 + (000011f4)
URL visited	
User Comments	Launching CorelDraw 11 in background. (Crash is no big surprise, I
wouldn't blame Firefox).
Since Last Crash	145779 sec
Total Uptime	145779 sec
Trigger Reason	SIGBUS: Bus Error: (signal 10)
Source File, Line No.	N/A
Stack Trace 	
libobjc.A.dylib.227.0.0 + 0x11f4 (0x913041f4)
EnsureParentMenu()
UnifyMenuList()
GetUnifiedMenuList()
MBarCalc()
DrawMenuBarWithContext()
DrawMenuBar()
nsMenuBarX::Paint() 
[/builds/tinderbox/Fx-Aviary1.0.1/Darwin_7.9.0_Depend/mozilla/widget/src/mac/nsMenuBarX.cpp,
line 720]
nsMacEventHandler::HandleActivateEvent() 
[/builds/tinderbox/Fx-Aviary1.0.1/Darwin_7.9.0_Depend/mozilla/widget/src/mac/nsMacEventHandler.cpp,
line 1387]
nsMacEventHandler::HandleOSEvent() 
[/builds/tinderbox/Fx-Aviary1.0.1/Darwin_7.9.0_Depend/mozilla/widget/src/mac/nsMacEventHandler.cpp,
line 551]
nsMacWindow::DispatchEvent() 
[/builds/tinderbox/Fx-Aviary1.0.1/Darwin_7.9.0_Depend/mozilla/widget/src/mac/nsMacWindow.cpp,
line 282]
nsMacMessagePump::DispatchOSEventToRaptor() 
[/builds/tinderbox/Fx-Aviary1.0.1/Darwin_7.9.0_Depend/mozilla/widget/src/mac/nsMacMessagePump.cpp,
line 589]
nsMacMessagePump::DoActivate() 
[/builds/tinderbox/Fx-Aviary1.0.1/Darwin_7.9.0_Depend/mozilla/widget/src/mac/nsMacMessagePump.cpp,
line 987]
nsMacMessagePump::DispatchEvent() 
[/builds/tinderbox/Fx-Aviary1.0.1/Darwin_7.9.0_Depend/mozilla/widget/src/mac/nsMacMessagePump.cpp,
line 455]
nsMacMessagePump::DoMessagePump() 
[/builds/tinderbox/Fx-Aviary1.0.1/Darwin_7.9.0_Depend/mozilla/widget/src/mac/nsMacMessagePump.cpp,
line 312]
nsAppShell::Run() 
[/builds/tinderbox/Fx-Aviary1.0.1/Darwin_7.9.0_Depend/mozilla/widget/src/mac/nsAppShell.cpp,
line 114]
xre_main() 
[/builds/tinderbox/Fx-Aviary1.0.1/Darwin_7.9.0_Depend/mozilla/toolkit/xre/nsAppRunner.cpp,
line 710]
_start()   start()
Timeless, did you mean the 1.7 branch?
See TB11656063, TB11678332.
Typically, crashes in libobjc are junk, in that they could happen for almost any reason. There are a few of these reports for Firefox 2.0.0.x and most of them are fairly random and nothing to really go on. Of those with that 0x11f4, they all happen on 10.3.x, which probably means Apple changed something in 10.4.x, but also, the frequency of the libobjc crashes went way down and happen in various other places.

If you can reproduce this somehow or give any sort of reproducible steps, please do. Otherwise, I think part of this bug was fixed in by Apple's update to Mac OS X and the rest are too few to gather reproducible steps from.

I'm going to close this as WFM because 1) I attempted to reproduce using some of the steps from talkback and couldn't and 2) it's pretty rare crash that most people can't cause (probably even less on 10.4).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
(Reporter)

Updated

9 years ago
Component: Widget: Mac → Widget: Mac
Product: Core → Core Graveyard
Crash Signature: [@ libobjc.A.dylib.227.0.0 + 0x11f4]
You need to log in before you can comment on or make changes to this bug.