When classifications are enabled, the bug ID is badly aligned when viewing a bug report

RESOLVED FIXED in Bugzilla 3.2

Status

()

RESOLVED FIXED
13 years ago
7 years ago

People

(Reporter: bernhard.merkle, Assigned: mkanat)

Tracking

2.20
Bugzilla 3.2

Details

(Whiteboard: [Fixed by blocker])

Attachments

(2 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

Hi there,

when you activate the categories option, which is new in version 2.20
I get a layout problem in the show_bug.cgi. The problem is, that the 
bug number is displayed as superscripted (compared to the label Bug#:)

please see attached screenshot for details.


Reproducible: Always
(Reporter)

Comment 1

13 years ago
Created attachment 199156 [details]
wrong layout when categories are activated
(Reporter)

Updated

13 years ago
Version: unspecified → 2.20

Comment 2

13 years ago
This bad UI has already been discussed in bug 156670 comment 11. myk and myself
couldn't find an agreement.

Updated

13 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Created attachment 202754 [details] [diff] [review]
patch v1: one-liner that fixes problem
Attachment #202754 - Flags: review?
Attachment #202754 - Flags: review? → review?(justdave)
Comment on attachment 202754 [details] [diff] [review]
patch v1: one-liner that fixes problem

Hmm, a long category name would cause that to get indented quite a ways...  there a reason this isn't just on a row by itself?

How about doing a vertical-align: bottom on the bug number?
Long classification names will cause indentation problems whether or not we let the header get break, since they're what's causing the indentation ("Bug#" itself is fairly narrow).  vertical-align: bottom would line the bug number up, but it won't fix the ugliness factor of a multi-line header.  Perhaps making classification its own field is the best option, although presumably whoever implemented classifications did it this way for a reason.

Comment 7

13 years ago
(In reply to comment #5)
> but it won't fix the ugliness factor of a multi-line header.  Perhaps making
> classification its own field is the best option, although presumably whoever
> implemented classifications did it this way for a reason.
> 

Having a separate field for the classification is my preferred solution, as already said in bug 156670. ;)
Comment on attachment 202754 [details] [diff] [review]
patch v1: one-liner that fixes problem

No sense leaving these things around forever.
Attachment #202754 - Flags: review?(justdave)

Updated

12 years ago
Assignee: myk → ui

Comment 9

7 years ago
We no longer display the classification in the bug report since Bugzilla 3.2, and so this is no longer a problem.
Assignee: ui → mkanat
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Depends on: 452733
OS: Windows XP → All
Hardware: x86 → All
Resolution: --- → FIXED
Summary: activating categories results in incorrect layoutstyle for bug number → When classifications are enabled, the bug ID is badly aligned when viewing a bug report
Whiteboard: [Fixed by blocker]
Target Milestone: --- → Bugzilla 3.2
You need to log in before you can comment on or make changes to this bug.