Wrong HTML Parsing of &image => [ampersand]image

RESOLVED INVALID

Status

()

RESOLVED INVALID
13 years ago
13 years ago

People

(Reporter: kilian, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

When somewhere in my HTML source is a [ampersand]image (&image) (e.g. a
parameter of an  url) the lovely firefox does parse it like some kind of
whitespace. Please check out the demonstration for details.

Reproducible: Always

Steps to Reproduce:
1. use a parameter for an url in the HTML source
2. name it &image ( [ampersand]image )
3. look at your website

Actual Results:  
a whitespace is shown instead of the thing i need

Expected Results:  
it should show &image [ampersand]image (cause otherwise many links e.g. posted
will fail cause of the whitespace)
You need to encode ampersands in HTML as "&", as you correctly did twice in
your testcase. Otherwise, the sequence might be interpreted as an HTML entity
(in this case, a fancy "I": see
http://www.htmlhelp.com/reference/html40/entities/symbols.html).
So I'm pretty sure the bug is invalid.

That said, the TEXTAREA case in your testcase actually does display "&image" in
trunk builds since about December 2004 (and therefore in the Firefox 1.5 betas).
This is likely due to fixing bug 88952 - although I'm not sure if it is correct.
(Reporter)

Comment 2

13 years ago
i agree that firefox should replace ℑ by the ℑ. BUT NOT &image (without
ending semicolon)...and oh god kill me, it works properly in IE :(
(In reply to comment #2)
> i agree that firefox should replace ℑ by the ℑ. BUT NOT &image
(without
> ending semicolon)...and oh god kill me, it works properly in IE :(

See bug 223838 and bug 242866 (both resolved as INVALID) about this. I'm going
to have to mark this one INVALID as well - sorry.

BTW, I submitted bug 312104 about the current inconsistent behavior in textareas.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.