Replying to message creates new Address Book entry when another for that address exists

RESOLVED DUPLICATE of bug 129393

Status

Thunderbird
Address Book
RESOLVED DUPLICATE of bug 129393
12 years ago
8 years ago

People

(Reporter: Anthony, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-GB; rv:1.7.12) Gecko/20050919 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-GB; rv:1.7.12) Gecko/20050919 Firefox/1.0.7

Using Thunderbird 1.0.6 or 1.0.7 (possibly prior versions as well), a new
Address Book entry is created when replying to a message even though an entry
already exists for that user.

For example, this entry already exists:
- First: Fred
- Last: Nerk
- Display: Fred Nerk
- E-mail: fred.nerk@nowhere-at-all.com
- Additonal E-mail: fnerk@nocompany.com
- Work: 0123456789
- Home: 0198765432
- Mobile: 0433995482

When replying to an e-mail from "Fred Nerk" <Fred.Nerk@nowhere-at-all.com> a new
Address Book entry is created:
- First: Fred
- Last: Nerk
- Display: Fred Nerk
- Email: Fred.Nerk@nowhere-at-all.com

This example has differences in lettercase, but duplicates are also created
where lettercase is identical.

Reproducible: Sometimes

Steps to Reproduce:
1. Create an Address Book entry:
- First: Fred
- Last: Nerk
- Display: Fred Nerk
- E-mail: fred.nerk@nowhere-at-all.com
- Additonal E-mail: fnerk@nocompany.com
- Work: 0123456789
- Home: 0198765432
- Mobile: 0433995482

2. Find an e-mail from "Fred Nerk" <Fred.Nerk@nowhere-at-all.com> and reply to it.

3. Check the Address Book to see if a new Fred Nerk entry has been created.
Actual Results:  
A new Address Book entry has been created:
- First: Fred
- Last: Nerk
- Display: Fred Nerk
- Email: Fred.Nerk@nowhere-at-all.com


Expected Results:  
A duplicate Address Book entry should not have been created. The details should
be considered equivalent to what's already there.

Account type: IMAP (to hMailServer v4.1-B136/MySQL on Windows 2000)

Installed Extensions:
- ConfigDate 0.3.0
- Contacts Sidebar 0.5
- Mozlla Calendar 0.8.3+
- Sort Extensions 2.1
- Sync Kolab 0.4.18

*** This bug has been marked as a duplicate of 129393 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
To the best of my knowledge this bug still exists in the main code.  To get it
fixed please go to bug 129393 and click the vote button to raise its level of importance.
You need to log in before you can comment on or make changes to this bug.