laiki.com - Broken banking site inaccessible in Firefox

RESOLVED FIXED

Status

RESOLVED FIXED
13 years ago
4 years ago

People

(Reporter: badjunk, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

This banking site uses several tricks that greatly decrease its usability and
partially block access for Firefox users.

Notable annoyances include:

1) Heavy usage of javascript:OpenURL(...) redirection links that not only break
tabbed browsing, but disable access to the site completely due to JavaScript
error (the variable "eipenoxaris2" is undefined);
2) Inability to login into e-banking site (the login page gets refreshed without
any error - this needs further investigation, probably server-side error);
3) Overlaying pages with invisible div that prohibits interaction with page
elements before everything is loaded.

Reproducible: Always

Steps to Reproduce:
1. Visit http://www.laiki.com/
2. Select "English"
3. Click any link that looks like "javascript:OpenURL(..., SameWindow)"
Actual Results:  
Nothing happened on the screen;
JavaScript error "eipenoxaris2 is not defined" generated in JS console.

Expected Results:  
Expected to access the relevant page.

Updated

13 years ago
Summary: www.laiki.com - Broken banking site inaccessible in Firefox → laiki.com - Broken banking site inaccessible in Firefox

Updated

13 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
*** Bug 360364 has been marked as a duplicate of this bug. ***

Comment 2

12 years ago
WFM on:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.8) Gecko/20061025
Firefox/1.5.0.8
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20061113
Minefield/3.0a1

Comment 4

12 years ago
Sorry, only read the first item. The site still appears wrong, of course.

Comment 5

12 years ago
(In reply to comment #3)
> http://www.laiki.com/web/w3cy.nsf/WebContentDocsByID/ID-D67180253347D1BEC2256B8A0041FCCF
> Invalid HTML, 

Opera 9 and Seamonkey are showing the same javascript error, if you click on one of the javascript:OpenURL(...) redirection links in the center. 

Line 98:
http://www.laiki.com/web/w3sr.nsf/Lookup/allNS6.js/$file/allNS6.js (Seamonkey)
http://www.laiki.com/web/w3sr.nsf/Lookup/allDOM.js/$file/allDOM.js (Opera)

Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8.1) Gecko/20061112 SeaMonkey/1.1b

Comment 6

12 years ago
Hm, this page works fine with Internet Explorer as well as with (very very strange) with an old mozilla browser 1.0.1 Mozilla/5.0 . Maybe some backward compatibility is necessary?
(Reporter)

Comment 7

11 years ago
Even though the site still wishes a lot to be desired in terms of web standards compliance, the most obvious glitches seem to be resolved by now.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.