Search from address bar doesnt work properly - returns search results for 'null' word

RESOLVED DUPLICATE of bug 130462

Status

SeaMonkey
General
--
major
RESOLVED DUPLICATE of bug 130462
12 years ago
12 years ago

People

(Reporter: Max, Unassigned)

Tracking

1.7 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915

When you close address bar with a 'show/hide' button (NOT wit view/hide/show
menu) then close Mozilla and reopen it again and make address bar appear again
(with 'show/hide' button - now its under personal toolbar) and perform search it
doesnt work properly. Search engine (the same with all three - google, askjeevs,
dmoz.org) will return search results for 'null' word not for the string/word you
were looking for.

Contrary to this if you hide address bar from View menu, close mozilla, open it
again, make address bar reappear again with View menu this bug DOESN'T exist -
search engine works properly and searches for what you want. (the same with all
three engines - google, askjeevs,dmoz.org)

Reproducible: Always

Steps to Reproduce:
1.Launch Mozilla Suite with address bar visible
2.Close address bar WITH the small button on the left (NOT with view/show/hide)
3.Close Mozilla
4.Open Mozilla
5.Make address bar visible again (with 'arrow button' under personal toolbar on
the left
6. Perform any search directly from address bar 

Actual Results:  
You should see that engine searched not for your word (or words) but for 'null' word

Expected Results:  
You should get the proper search results. Results for the string you put into
the address bar and not for 'null' word.

Modern theme.
(Reporter)

Comment 1

12 years ago
What I refer to in my bug report as 'address bar' is in fact 'navigation
toolbar' sorry for that mistake.

Comment 2

12 years ago
The same for me with the 1.7.12 on Windows. The 1.7.11 was OK.

Comment 3

12 years ago
The solution:
edit C:\Program Files\mozilla.org\Mozilla\searchplugins\google.src
replace line:
<input name="sourceid" value="mozilla"> 
with line 
<input name="sourceid" value="mozilla-search">

(Reporter)

Comment 4

12 years ago
(In reply to comment #3)
> The solution:
> edit C:\Program Files\mozilla.org\Mozilla\searchplugins\google.src
> replace line:
> <input name="sourceid" value="mozilla"> 
> with line 
> <input name="sourceid" value="mozilla-search">
> 
I already have the line that you ask to put which is <input name="sourceid" value="mozilla-search"> in the sepcified file. So please try to think of some other solution/reason for my problem.
I also ask others to check if its only me or others have this problem AND the proper line in the specified file.

Comment 5

12 years ago
this is fixed on trunk and should also be fixed for SeaMonkey 1.1

*** This bug has been marked as a duplicate of 130462 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Version: unspecified → 1.7 Branch
You need to log in before you can comment on or make changes to this bug.