Closed Bug 312172 Opened 16 years ago Closed 16 years ago

SVG "em" notation in the <tspan> "dy" attribute is not being correctly implemented

Categories

(Core :: SVG, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 312165

People

(Reporter: johannes.wierny, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4

It seems the "em" notation in the <tspan> "dy" attribute is not being correctly
implemented. Using the same code with absolute values i.e. dy="10pt" the SVG is
correctly displayed. The same graphic using "em" is also correctly displayed in ASV.

Reproducible: Always

Steps to Reproduce:
Use the following SVG code:

*****
<?xml version="1.0" encoding="UTF-8"?>
<svg xmlns="http://www.w3.org/2000/svg"
xmlns:xlink="http://www.w3.org/1999/xlink" contentStyleType="text/css"
height="100%" version="1.0" viewBox="0 0 1190.55 841.89" width="100%">
	<style type="text/css">
	<![CDATA[
		.style1
{fill:#ffffff;stroke:#000000;stroke-linecap:round;stroke-linejoin:round;stroke-width:0.72}
		.style2 {fill:#000000;font-family:Arial;font-size:12pt;font-weight:bold}
	]]>
	</style>

	<g>
		<g id="rect1">
			<rect x="0" y="1.44" width="187.087" height="29.7638" class="style1"/>
			<text x="28.53" y="12.72" class="style2">Text1 Text2 Text3<tspan x="66.22"
dy="1.2em">Test 4</tspan></text>
		</g>
	</g>
</svg>
*****
The code above will show the incorrect implementation.

Actual Results:  
The first text line is superimposed by the second text line. 

Expected Results:  
The second text line should be displayed below the first text line.

*** This bug has been marked as a duplicate of 312165 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.